Journey steps and map locations

Game mode: Online
Problem: Bug
Region: Here

Hello. I’ve created my own dedicated server and have some problem: when I join the game and open some map location or finish some journey steps and then disconnect and connect again my map is clear and journey as well. I cannot finish those journey steps again and cannot open map location. Does anyone know how to fix it? Thanks!

Steps on how to reproduce issue:

  1. Create new player
  2. Open some journey steps or map location
  3. Disconnect and connect again
  4. Look that journey steps are empty and the map is clear.

I heard suicide can fix that problem. Or a similar one. I forget.

Server restart will fix it

Also online and journey problem… some icons are missing like throwing orb, BUT
The biggest issue is that damn light armor. wearing a relic hunters armor and still that one haven’t been fulfilled.
Also tried derketo’s ■■■■ outfit, and the standard light armor too.

It is working on single player tho. But not on official servers. <- hope this info helps.

1 Like

Try the sandstorm mask. I saw on a few threads that it worked.
I haven’t tested it myself though, I play single player and don’t have the same problem.

1 Like

Not tested myself but there are ppl complaining to that journey and some of them using sandstorm mask when it is time for that…

Anyway thank you for the information. If that works on some ppl and not on others, that would be an even bigger problem tho.

Yeah. There’s quite a few broken/weird things with the journey…

For example, I survived many sandstorms without shelter yet I did not complete the journey for it until I wore the sandstorm mask. If that’s the requirement, it should say wear the mask, not to simply survive!

And “Use an explosive”. Can’t complete that by using explosive traps. Why not?

And many more strange things!

1 Like