Keyboard key problems

** Game Mode: ** All Game Modes
** Type of problem: ** Keyboard Key Recognition
** Type of server **: the 3 type
** Region: ** North America East

[Describe the bug here]

***Hello, definitely the keyboard game problems increase with each update. I would like to know if there is a way to change its keyboard keys and that the game take the changes into account because I can change my settings the game does not seem to want to change the keys even if we see the changes in the settings.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide, the easier it will be to find and fix the bug:
1.Change the keys in the parameters (example key “E” for “Sprinter” but does not work
2.Tried different key configurations

Lt, sorry you are having these problems. Could you check a few things to see if it helps?

In: F:\Steam\steamapps\common\Conan Exiles\ConanSandbox\Saved\Config\WindowsNoEditor
Check for read-only on the file Input.ini and the containing folder. If so, change it.

In: F:\Steam\steamapps\common\Conan Exiles\ConanSandbox\Config
Check for read-only on the file DefaultInput.ini and the containing folder. If so, change it.

Your path will vary from the above, but I trust you can find them.

Good luck !



Hello, thank you for your answer. I checked if the folders and files were read-only and they were not. For some reason I can change some keyboard keys that are recognized by the game on my standard keyboard but are not recognized on my Zboard keyboard even if it’s exactly the same keys. Example I change the keys of “Sprinter” with the N key that works if I use the standard keyboard but using the N key on my keyboard Zboard it is not recognized, but if I change the N key in the game for another action than the “Sprinter” then the key is recognized.

The input.ini file needs some serious housekeeping. It has multiple mount actions scattered throughout the list, is missing movement settings, and has multiple versions of some commands and not others. I’m here because I changed several keybindings including the one for “TOGGLE TARGET LOCK” in game and couldn’t check the durability of my building tiles, so I changed back to default temporarily. I changed my keybindings back to how I had them and thought I lost the ability to dodge because I kicked instead of dodged. When I tried rapidly pressing my dodge button(bound to LeftControl), I kicked then dodged, kicked then dodged (turns out that the input.ini has multiple “SecondaryactionV2” entries scattered throughout the list which is conflicting with the multiple “DodgeActionV2” entries scattered throughout the list and giving priority of LeftControl to “SecondaryactionV2”). Then I bumped LeftAlt and dodged even though it’s not bound to anything (turns out LeftAlt is somehow still bound to a seperate “DodgeActionV2” entry in the input.ini file)! I tiried to clear all keybindings in game, and I was still able to move, so I juxtaposed forward and backward(“S” for forward and “W” for backward) and now I can’t move (most likely trying to go forward and backward at the same time)! I eventually started digging through config files to force the keybindings to work just to find the absolute mess your Input.ini file is.

First of all, it’s not my file, it’s yours. The file you are looking at is in windowsnoeditor and is set by changing settings ingame. The defaultinput.ini is in the folder Config up several levels and is provided and updated by Funcom.

As described to me, whatever changes you make in game is stored there. The game uses those settings to override the defaultinput.ini so your customizations are kept. The order of the settings are not considered; any order is fine and under normal conditions, no one should have to look at it.

The file only contains settings you have changed and the game uses the default for all the others.

With all the fiddling you have done without understanding the above, I suggest you delete the input.ini file in the windowsnoeditor folder and start over. If you want the lines in some kind of order, change your settings in that order, while ingame.

I reviewed my post above and could find no advice that stated you, or anyone else, fiddle with the contents, but apparently you know just enough to get into some sort of condition that does not suit you. Good luck.



1 Like

Huh, the way you worded your first reply indicated it was an official response from Funcom. Even if that isn’t the case, it is in fact Funcom’s file since the EULA clearly states we don’t own anything, we are just renting. Apparently the wording in my reply was bad, because I didn’t fiddle with anything in the file, I just looked at it and found out how much of a mess it is. I have only changed setting in the game, and your belief that the entries in the file are in chronological order they are set in game is completely false because it has 3 entries for mounts at the top and that was not the most recent keybinding changes I had made. I made no changes whatever to controller keybindings and those are the first and last entries in the file.

LtColonel_Forest’s reply makes it pretty obvious that it’s not a permissions problem causing the keybindings to be FUBAR. I just included what I found out about the file to make it easier to squash the bug. I’ll try completely deleting the file, but not hopeful because I reinstalled the game twice, making sure all the files were deleted before the last install, and it hasn’t helped. It looks more like the game isn’t prioritizing the entries in input.ini over the entries in defaultinput.ini anynmore.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.