Legendary Armor Rep. Kit - not available to craft ?!

Hey there, i was searching for way´s to repair my legendary and Epic Staff.
I already found the info, that you can craft it by your own with the right thralls. So i was curious and tried it in the admin mode.

The Rep-Kits for the weapons will appear in the desk if i set the T4-Weaponthrall in, all fine. But the Armorer won´t be able to make the Legendary Kit, just the Master Kit.

Is that a known issue or did i just spawn the wrong Armorer?! I Tried all armorers which i found about the Adminmenu in T4 (durability, armor, weight) But nobody has that recipe.

Thanks in advance for your help!

Best Regards

Just farm Unnamed city bosses, they will guaranteed drop either legendary armor or legendary weapon patch kit.

I found Hyam Hammerhand in Sepermeru.
He can make the legendary kits.
You need the blue hammer in the corner of the thrall profiles.

you sure it is the legendary not the master repair kit ? I have 3 different armorers whit the hammer and they all only making the master armor repair kit

Unfortunately i can’t post screenshots because i’m new here.

Did you level all the repair kits for yourself in the knownledge category?
I don’t know if that has an impact on the possebilities in the Tinker’s bench.
Also the thrall needs to be a Tempersmith or Temperwright

yes i have all unlocked

I guess it’s not the right thrall then.
It has to be a Tempersmith or Temperwright.
Ours is called Hyam Hammerhand. Maybe search for him and try it.

I can confirm this bug. No temperwrights on my server are making them. Someone else I talked to on the server said the same. I didn’t even notice until they said it. The legendary patch kit is replaced with a master kit at the top. I believe some others on this forum have said the same is happening.

Just a follow up with screenshots from three different temperwrights. Notice there’s no purple brackets on the patch kit icon. It’s a master, not legendary. Fyi, I’m on PlayStation.

1 Like

Ok, that sucks.
I wish i could upload a screenshot.
We can see the legendary

1 Like

That’s a blacksmith… not at an armorsmith. Blacksmiths are working as they should… just the armorsmiths are bugged.

Ah, alright.
I understood it that way that nothing was working for Sir_Schnitzl

Yeah I made the same mistake when the person on my server said it. Upon further inspection, I noticed it as well. You may want to double check your armorsmiths work.

I just found one…he’s still in the wheel :wink:
We will check it out tomorrow. Should be ready then…But i guess we will have the same issues as you guys.

Sorry if I didn´t explain it good enough :sweat_smile:

The weaponsmith-Kit is working, just the armorer is the problem.

Thanks for all your reply´s ! So my question is answered ^.^
Happy farming then for these kits :sweat_smile:

1 Like

Just checked. Weapon kits are still good, but armor can’t be made.

Confirmed with other players on the server.

Can confirm this current bug, tested in admin mode with all available temperwrights - they have a special craft for the Master Armor Patch Kit, not the Legendary Armor Patch kit as expected.

This bug has been around for about a week at least.

You explained it fine i think…i just totally misunderstood it :laughing:
But yeah, it’s not working.
I hope it get’s fixed!