Lifeblood Spear is not working

Game mode: [Online | Singleplayer]
Problem: [ Bug ]
Region: [ALL]

[Lifeblood Spear is not working when it is equipped.]

Steps on how to reproduce issue:

  1. Take Lifeblood Spear
  2. Equip Lifeblood Spear
  3. And Not happing
1 Like

Hello @vanch, thank you for getting in touch!

This spear was tweaked and it now regenerates 1 hp every 5 seconds, as long as you keep wielding it, is this not the case?

No. It doesnt work at all.very disappointing.

Was it looted before the update or after?

Have you tried allowing your character to die and equipping it after the respawn?

Yes, I have tried after die, after relog, dropped it on the ground and keep it on the vault.
I tried with different characters.
But not working, I have killed the dragon several times again and the new loot does not work too.

It is sad, I really like this spear.

1 Like

Thank you for sharing additional details, we’ll be sending note to the QA team to see if they can track this one down!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.