Looking for a guinea pig!

The title says it, I’m looking for a guinea pig, preferably a geeky one, to test something on Windows
Warning: it might get technical :smiley:
Quick resume: I’m not using Windows as OS, but Linux \o/
Games can run on linux, using a software called Wine, which basically intercepts the windows system calls made by an executable (.exe), and translates them into linux system calls. Thing is DirectX being Microsoft patented, it’s not available on linux, and Wine turns the DX calls to OpenGL, but the performance is sometimes terrible on modern games.
There comes DXVK, a set of .dll which turns DX 9/10/11 calls to Vulkan ones, and allow linux gamers to play lots of games; that’s how I can play SWL (another example I can run Witcher 3 flawlessly).

I’m actually wondering if the dxvk dll set can be used on Windows (they’re not made for it) and if it’s possible to run SWL using it, hence the title “Looking for a guinea pig”.

Warning again: I shall not be held responsible if your computer catches fire or something bad happens, that’s why I asked for a geeky person, who knows how to repair his OS in case all things go awry.

Return of the warning: You have to run SWL in DX11 (see why below).
Yet another warning: It will not magically fix the game crashes linked to Dx11, the game still uses and sends Dx11 calls, but dxvk will “convert” those to Vulkan and feed them to your gfx driver.

Instructions for the curious ones without fear:
Check your gfx card driver is up to date.
Grab the DXVK dll here, make sure to grab the last version.
Unpack them, 7Z file manager should be able to open the .tar.gz, stop using winrar !
You should get a dxvk folder, containing 2 folders (x32 & x64) and a setup_dxvk.sh file. Forget the setup file, it’s a linux script !
Open your SWL installation folder (where you can find SecretWorldLegends.exe and SecretWorldLegendsDX11.exe).
SWL being a 32bit software (I think, please correct me if it’s actually 64bit), go in the x32 folder, copy the d3d10* d3d11 and dxgi (.dll) files, and paste them into your SWL folder.
Do NOT, I repeat, do NOT copy the d3d9.dll, it does screw up the launcher. (Or if you wanna try, copy it, and tell me if that works for you; when I do, the launcher doesn’t have clickable button to start the game)
Now, cross your fingers, and launch the game

x64 experiment: After browsing the SWL folder, I finally opened my eyes and noticed many dlls (APEX* PhysX* etc…) are actually available in both 32 & 64 bits.
Could anyone adventurous try the experiment but using the 64b dxvk instead of the 32b one ?

If it works for you, please report it, and let me know if the performance is better/worse compared to dx11.

I shall repeat it once again, the dxvk dll set was made for Linux, Windows is not supported. But a websearch “dxvk on windows” led me to believe some people managed to use it on other games.

Congratulations, you’ve read my whole post ! Now read the warnings again.

Edit: seems the dxgi has to be installed on Windows, so I modified the instructions.
Edit: added the x64 part

A bit off the topic here :wink:
I would suggest to have both. I’ve come across sequential files that sometimes unpack with errors on 7Zip, while WinRAR does it flawlessly. The opposite is also true.

Reddit says it works. https://amp.reddit.com/r/pcgaming/comments/hirdfp/dxvk_is_amazing_on_windows/

I’ve seen the reddit thread, but didn’t read it fully.
But the mad scientist in me still wanna know if it gives better perfs with SWL than native dx11 [insert Dr Klein’s laughter here]

Edit: + I’d like to know if someone can make the launcher work using the d3d9 dll on Windows

Didn’t work for me. I had the same launcher freeze with d9, and otherwise it would crash after the launcher.

Guess you can’t trust reddit then :stuck_out_tongue:

@rephaim Could you give it another try with both the d3d10* d3d11 and dxgi.dll ?

I’m guessing it’s because AMD already runs vulkan drivers and it doesn’t like the generic version.

Dxvk is not a driver, it’s a wrapper
And it’s actually supposed to run better on amd cards, since the Vulkan API has been built upon the ashes of AMD’s Mantle API

You’re splitting hairs as far as definitions go. Regardless, the game runs great with the AMD version that the official software updates with drivers, but the generic ones break it. 70-130 fps is my normal range, rarely it goes below 60 fps yet when it does it would have been a single-digits fps slideshow on the nvidia hardware I used to run.


So far, only rephaim was willing to give it a try, and it didn’t work for him on his amd card.
Is there anyone else (AMD or Nvidia user) who could test this and report his experience please ? If you’re up to, read the first post entirely, thanks :slight_smile:

Ok, I tried it. (RTX 280 Ti, drivers not updated since October)

d3d9.dll does indeed break the launcher.

With the new dll files, the game still runs. When I first loaded in, the game was chugging pretty bad, with lots of frame drops. That stabilized shortly.

FPS tests were done in the central Agartha Hub.

(Normal Setup)
74->120 (Facing towards center / Bank NPCs vs facing wall behind npc vendor)
45-75 (65 most of the time) - running around in circles around Bank NPCs.

(DXVK dll)
55->95 (Facing towards center / Bank NPCs vs facing wall behind npc vendor)
48-59 (mid 50’s most of the time) - running around in circles around Bank NPCs.

Certainly seems to perform worse, but not stupidly worse, based on this very limited test.

1 Like

@Piankhi Yay, results \o/
Thanks for trying, and confirming the d3d9 issue. Good to hear it works, yet a bit sad about this performance loss, but well these dlls were not made for Windows.
On a side note, your normal setup perfs are a bit disappointing on a 2080, I guess the engine really needs optimizations (like that’s ever going to happen lol)

More testers are welcome, amd, nvidia, or 3DFX users ! :smiley:

1 Like

Tried again with the 10core and other libraries.

AMD (Vulkan 1.2.159): 70-130 fps
Vulkan 1.7.3: 55-115 fps

1 Like

I was running at 2560x1440, but the main thing with Funcom MMOs is they are mostly single-threaded, so the CPU is almost always the bottleneck anymore.

1 Like

Thanks @rephaim for trying again ! The perf loss seems more contained on AMD card.

@Piankhi Ah yes probably, but well…
Multithreading: expectations VS reality :smiley:


After browsing the SWL folder, I finally opened my eyes and noticed many dlls (APEX* PhysX* etc…) are actually available in both 32 & 64 bits.
Could anyone adventurous try the experiment but using the 64b dxvk instead of the 32b one ? (There’s a way to install both, but that’d require breaking Windows imo)

I’m running on a GTX 970 (6 ½ years old card), 1920x1080 borderless window, check the FPS in the up left corner, it oscillates between 50-75, depending where I’m watching, and the number of people in sight)

Of course there’s never really 1:1 comparison but I have a 1070 GTX at 1920x1200 windowed, video settings 3 across the board, and my DX9 performance is pretty atrocious. on the plus side it doesn’t crash. (even running circles round the bank NPCs I get >60 fps on dx11)

[edit] 68-69 fps with DXVK DX9 as mentioned ingame.

Running DXVK in DX9 mode did spam the log with a bunch of this, which might explain my visual issues (or point to a DXVK config problem):

warn: ConvertFormat: Unknown format encountered: D3D9Format::AL16
warn: ConvertFormat: Unknown format encountered: D3D9Format::R16

It also appears my screenshot button does not work with DXVK enabled, just shows the splash screen.

The game’s playable so I’ll leave it on for a bit and see how it performs w.r.t. crashing randomly but it is quite ugly, something’s wrong with the lighting.

I said ingame but I’ll write down here as well:
no luck with DX11 DXVK, when I launched the game it would revert to DX9 on its own and not be using it.

Thanks @Onevia for testing, and kudos for making it work in Dx9 :+1:

Both warnings are probably caused by a texture format unsupported by Vulkan specs (either too old or too rare). There was such an issue with Witcher 3 (some swamp mobs would be invisible because they were using a morphing texture as they explode when dying), and the Vulkan devs created a new extension so DXVK would work with those rarely used functions in some games.

The ugliness you described doesn’t appear on my client, so it could be specific to Dx9 to Vulkan conversion. I’ll try to reproduce if i manage to launch in Dx9.

Weird you can’t start in Dx11, fact it goes back to Dx9 on its own seems more a client issue to me, dxvk isn’t modifying any config file.