Looking for a guinea pig!

You’re splitting hairs as far as definitions go. Regardless, the game runs great with the AMD version that the official software updates with drivers, but the generic ones break it. 70-130 fps is my normal range, rarely it goes below 60 fps yet when it does it would have been a single-digits fps slideshow on the nvidia hardware I used to run.


So far, only rephaim was willing to give it a try, and it didn’t work for him on his amd card.
Is there anyone else (AMD or Nvidia user) who could test this and report his experience please ? If you’re up to, read the first post entirely, thanks :slight_smile:

Ok, I tried it. (RTX 280 Ti, drivers not updated since October)

d3d9.dll does indeed break the launcher.

With the new dll files, the game still runs. When I first loaded in, the game was chugging pretty bad, with lots of frame drops. That stabilized shortly.

FPS tests were done in the central Agartha Hub.

(Normal Setup)
74->120 (Facing towards center / Bank NPCs vs facing wall behind npc vendor)
45-75 (65 most of the time) - running around in circles around Bank NPCs.

(DXVK dll)
55->95 (Facing towards center / Bank NPCs vs facing wall behind npc vendor)
48-59 (mid 50’s most of the time) - running around in circles around Bank NPCs.

Certainly seems to perform worse, but not stupidly worse, based on this very limited test.

1 Like

@Piankhi Yay, results \o/
Thanks for trying, and confirming the d3d9 issue. Good to hear it works, yet a bit sad about this performance loss, but well these dlls were not made for Windows.
On a side note, your normal setup perfs are a bit disappointing on a 2080, I guess the engine really needs optimizations (like that’s ever going to happen lol)

More testers are welcome, amd, nvidia, or 3DFX users ! :smiley:

1 Like

Tried again with the 10core and other libraries.

AMD (Vulkan 1.2.159): 70-130 fps
Vulkan 1.7.3: 55-115 fps

1 Like

I was running at 2560x1440, but the main thing with Funcom MMOs is they are mostly single-threaded, so the CPU is almost always the bottleneck anymore.

1 Like

Thanks @rephaim for trying again ! The perf loss seems more contained on AMD card.

@Piankhi Ah yes probably, but well…
Multithreading: expectations VS reality :smiley:


After browsing the SWL folder, I finally opened my eyes and noticed many dlls (APEX* PhysX* etc…) are actually available in both 32 & 64 bits.
Could anyone adventurous try the experiment but using the 64b dxvk instead of the 32b one ? (There’s a way to install both, but that’d require breaking Windows imo)

I’m running on a GTX 970 (6 ½ years old card), 1920x1080 borderless window, check the FPS in the up left corner, it oscillates between 50-75, depending where I’m watching, and the number of people in sight)

Of course there’s never really 1:1 comparison but I have a 1070 GTX at 1920x1200 windowed, video settings 3 across the board, and my DX9 performance is pretty atrocious. on the plus side it doesn’t crash. (even running circles round the bank NPCs I get >60 fps on dx11)

[edit] 68-69 fps with DXVK DX9 as mentioned ingame.

Running DXVK in DX9 mode did spam the log with a bunch of this, which might explain my visual issues (or point to a DXVK config problem):

warn: ConvertFormat: Unknown format encountered: D3D9Format::AL16
warn: ConvertFormat: Unknown format encountered: D3D9Format::R16

It also appears my screenshot button does not work with DXVK enabled, just shows the splash screen.

The game’s playable so I’ll leave it on for a bit and see how it performs w.r.t. crashing randomly but it is quite ugly, something’s wrong with the lighting.

I said ingame but I’ll write down here as well:
no luck with DX11 DXVK, when I launched the game it would revert to DX9 on its own and not be using it.

Thanks @Onevia for testing, and kudos for making it work in Dx9 :+1:

Both warnings are probably caused by a texture format unsupported by Vulkan specs (either too old or too rare). There was such an issue with Witcher 3 (some swamp mobs would be invisible because they were using a morphing texture as they explode when dying), and the Vulkan devs created a new extension so DXVK would work with those rarely used functions in some games.

The ugliness you described doesn’t appear on my client, so it could be specific to Dx9 to Vulkan conversion. I’ll try to reproduce if i manage to launch in Dx9.

Weird you can’t start in Dx11, fact it goes back to Dx9 on its own seems more a client issue to me, dxvk isn’t modifying any config file.

Oh yeah, forgot to report in mine that I also saw it trying to force dx9 and it took some hacky clicking around various buttons to get it to switch to dx11.

Okay, tested with dx9 & dxvk

I don’t see any lighting issue, neither on my character …

… or on the ground texture, and char shadow :face_with_hand_over_mouth:

@Onevia Is that the ugliness you had ? Should that be the case, don’t force yourself playing like that, and go back to Windows native DirectX (unless dxvk really improves the game stability, which I highly doubt)

Interesting fact: I also tried with game set on dx9, and dxvk disabled (meaning Wine uses its default DirectX to OpenGL conversion) and the graphic result was the same. So (theory) it could be caused by the way the game engine handles the lighting in dx9 (using some exotic way?), but only the devs got the answer I guess (if you guys are reading us, let us know!). Maybe I could ask the dxvk devs what they think about that, but I’m too busy grinding distillates for now :stuck_out_tongue:

Yes, that face half shadow thing is the same as I saw. I guess TSW/SWL uses some weird single channel texture mode for all their shadowmaps. (AL16 should be alpha-luminance 16 bit per channel if I understand dds format naming correctly, R16 is… only red and 16 bit channel)

For anyone running Steam and also using nvidia hardware, try signing up for Steam (beta) and see what if anything this update does anything for SWL performance.



Spent a week with the DX9 DVXK as I said. Overall framerates were smoother than DX9 and I saw 0 crashes in I suppose 4-5 hours of gameplay across the week, but… very obvious graphical artifacts. The worst place for that was NYR, it already overlaps a ton of effects having 10 players attacking and the artifacts made the ground a lot darker so it was hard to see the fist telegraphs. I’ll probably wait until I hear an update on it before I keep using it.

Did you adjust gamma?

I don’t think that would help much, the problem is it’s dark grey ground with a grey and white telegraph and then a dozen brightly coloured casting effects on top (2 npcs + whoever’s using grenades, chaos, etc.)

1 Like

Thanks @Onevia for testing for so long ! Too bad dxvk doesn’t render correctly the game lighting (although I wonder if it’s not the game client who got unusual ways of rendering lights). I should really post on dxvk git and ask the advice from devs.