Lost UI Element (not on screen)


#1

/reloadui doesn’t seem to bring it back.

Using the unlock (upper right) doesn’t bring it back on the screen to move. I originally moved it testing out much higher resolutions.

Where are the X,Y coordinates for UI elements saved when you drag them around?

Or…what is the /setoption command for the ‘interact’ window, so that I might set it to something like 800x600, just so I can see it again, then move it where I want?

By ‘interact’, I mean the little yellow indicator that pops up and tells you to hit F.

Not ordinarily an issue, since most things in game is just a ‘use’. But when you are trying to do “Red Handed”, it’s a real problem. :grin:


#2

Window positions are generally saved in your character’s Prefs_2.xml. I don’t know if that’s the case for the interact UI since we’re not even supposed to be able to move that.

%localappdata%\Funcom\SWL\Prefs\accountname\charID\Prefs_2.xml

If you can’t find it there (I couldn’t, but I never moved it in the first place) you might have to reset your entire UI using the DEFAULT button in Interface Options.


#3

It lets you drag it when you unlock the gui elements, so I did. :disappointed:

I’ll look around in that file, thank you. I also found this and see an ‘interaction_gui’, but no specific X,Y. Maybe that’s an enable/disable (true/false) setting.


#4

I had this problem myself once, I threw something off the side of the screen for erm… Reasons…

I got it back by selecting a much higher resolution than I would normally use then dragged it back into the middle before setting screen size to playable once more.


#5

The interaction UI doesn’t even show up as a movable element when I unlock my UI. No idea why it does for you. But if you moved it, maybe you can find the coordinates in the prefs file now.


#6

I didn’t see it, but that was a good thought. Don’t remember how I moved it, but I remember moving it, since at higher resolutions, it’s not next to your character, but way up to the left.

I think I’m going to have to do Lunas suggestion.


#7

Did some more digging in that file, Aeryl, and I think I found it!

/setoption UseIconX n
/setoption UseIconY n

Changed it to 800 and 600, respectively, and it’s back on the screen now! Albeit not in an ideal place. But, it’s totally a draggable thing, at least for me, when you unlock the UI. It’s called ‘Examine’.

Thank you both again!


#8

Oh, I think I might know why you might not be seeing it to drag it. You have to be looking at an object to interact with to see it to move it, even when the UI is unlocked. Maybe that is why?


#9

No, I tried that. It never shows up as a movable element and it can’t be moved even if I click where it should show up (as it disappears as soon as you hit alt). It’s possible that Trash Scaler or another mod you have installed makes it movable, but it definitely isn’t by default.


#10

Maybe another mod? I have TrashScaler turned off right now (though, still ‘installed’, so maybe). The author did say they couldn’t resize that element, though. Plus, that X,Y setting I found is just a normal positioning setting. Very weird.


#11

There are a ton of /setoption commands that let you change things that aren’t exposed in the UI and should be treated as “use at your own risk”. Including the semi-functional scaling mode you played around with before.

Maybe @Glaucon could comment on whether or not we’re supposed to be able to move the interaction UI in GUI edit mode, because I certainly can’t (not that I would want to, it’s fine where it is).


#12

I’d be curious to know that too. I didn’t use any /setoption commands on that element in the beginning. If I had, I would have remembered doing that, and my question wouldn’t exist! :blush:

I just remember dragging it over, as I dragged other things around, when I was first testing things like GUIResolutionScale, vs some of the /setoptions you dug up for me (thanks again!), and then ultimately ‘not’ using any of those, and just going with a combination of TrashScaler and changing all the things you can change with sliders in the options menu.

Then I realized how much of an FPS hit I was taking (it wasn’t really noticeable in GW2) after it started feeling sluggish, so for now I’ve gone back. My equipment is a little bit older, and I envision upgrading sometime in the next 12 months, and think I’ll try again then (with any game I happen to be playing at the time, hopefully still this one).


#13

I’m not Glaucon, but I can say I’ve been able to move the interaction UI from day one, and usually do move it a smidge. I haven’t tried since the last patch, but my one month old alt could move it. Are you using any mods that alter that UI?


#14

No, but I just found the solution. The interaction UI can only be moved if you have “Mouse mode overlay” enabled.

I’ve had that off since beta. Looks cleaner, IMO.


#15

What does ‘mouse mode overlay’ change?


#16

It darkens the screen, adds a little logo and the text “[ALT]: Toggle HUD Interaction Mode” to remind you that you’re in alt mode. With it disabled, the screen stays normal and alt mode just unlocks the cursor.


#17

I was looking at this too, and I have that enabled as well. Or, at least, that is how my screen behaves when I hit ‘alt’.

Do you happen to have ‘Show Interaction UI’ checked under the ‘Interaction’ tab? That’s the only other thing that jumps out at me as to why you don’t see it.

Just a curiosity at this point, as to why some people might not be able to move that. :slight_smile:


#18

It’s literally just the overlay that causes it. Overlay on = “examine” movable. Overlay off = “examine” disappears from the GUI editor.


#19

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.