Maelstrom settings issue

StormEnabled=True ElderThingsEnabled=True keeps getting deleted by serversettings.ini, anyone have a idea?

I tried “EnableStorm=True” it wont get removed.

Running Windows 2016, dedicated server.

my serversettings.ini doesnt save like posted by the admin "StormEnabled = true; ElderThingsEnabled = true;

Maelstrom wont show up at all.

same problem , anyone knows how to fix it?

@LynX The settings get deleted because you are using the default values which are also listed under DefaultServerSettings.ini. If you use other value than the default, they will stay.

About the storm not showing even though it is being enabled: how long have you waited after the last server restart?

@evo361 your issue is the settings not saving or the storm not starting and if it is the 2nd, how are you running the server (self-hosted via the dedicated launcher or rented slotted server by some hosting company)?

Well it randomly deactivates itself, not sure what is causing it. Ive set it on, onto 3 servers, all got it working, after a restart, on 2 its working and 1 its gone again.

Like the vars keep getting changed by itself.

Hi, is this a known bug?

I am getting no maelstrom on both my dedicated server and my singleplayer witch are on two different machines.

StormEnabled = true
ElderThingsEnabled = true

I have those two settings enabled on both instances.

Maelstrom is enabled between 00:00 and 23:59 from monday to sunday
Accumulation time is 15
Duration time is 30
Dissipation time is 2

I have tried reducing the maelstrom cooldown to 1

The maelstorm is working on my private server with default settings:

StormEnabled = true
ElderThingsEnabled = true
ElderThingsIdleLifespan = 30.000000
SiegeElderThingsEnabled = true
StormCooldown = 75.000000
StormAccumulationTime = 15.000000
StormDuration = 30.000000
StormDissipationTime = 2.000000
StormEnduranceDrainMultiplier = 1.000000
ElderThingSpawnRate = 1.000000
StormTimeWeekdayStart = 0000
StormTimeWeekdayEnd = 2359
StormTimeWeekendStart = 0000
StormTimeWeekendEnd = 2359
StormMinimumOnlinePlayers = 0
StormBuildingAllowed = false
StormMapBlocker = true
ElderThingSiegeDamageMultiplier = 1.000000
MinimumBuildingSizeToBeSieged = 41
AmbientElderThingRespawnRate = 1.000000
SiegeElderThingRespawnRate = 1.000000
StormBuildingDamageRateMultiplier = 1.000000
MaxAmbientElderThings = 200
MaxSiegeElderThings = 5
MaxAmbushElderThings = 200
ElderThingSiegeBuildingSizeMultiplier = 1.000000
StormBuildingDamageEnabled = true
SiegeElderThingMapMarkers = false
MinimumStormDamageBuildingPieces = 0
StormBuildingDamageMultiplier = 1.000000

2 Likes

I haven’t touched/changed the default settings for the Maelstrom and its been working fine so far in single player.

1 Like

Hi, so the problem was that my Maelstrom settings were changed. As soon as I change 1 setting it makes it not spawn at next reboot.

This has to be this:
StormCooldown = 75.000000
StormAccumulationTime = 15.000000
StormDuration = 30.000000
StormDissipationTime = 2.000000

now my server crashed, and the maelstorm aint working again.

i remember these issues when purge got released first time in the past.

@LynX @Nasdan97 Can you tell me what you are trying to achieve as settings in order for me to test it on my test server?

Last night I had clear sky over island for RL hours no surge no maelstrom nothing
checked my server today and I had all siptah settings missing from ini
haven’t touched them prior, but now I pasted defaults

If you don’t have anything in the ServerSettings.ini the game used the ones in DefaultServerSetting.ini. There seem to be some settings that always stay in the ServerSitting.ini even if defaul values are used and another set of setting which get cleared if they are matching the default. The setting may also be deleted if you use incorrect syntax.

After 2 days of trying I’ve finally gotten the Maelstrom on my server.
I reset all settings via the admin panel, and then I notice a few lines stayed in the server.ini file, namely -
StormBuildingAllowed = true
StormBuildingAllowed = false
StormBuildingAllowed = false
DecoupleSurgeFromStorm = false
DecoupledSurgeCooldown = 5

stopping the serve and then removing these, and the maelstrom started straight after the server started

1 Like

I’ve noticed also that the vars in the serversettings are duplicating, its pretty buggy.
"
StormMinimumOnlinePlayers=0
StormMinimumOnlinePlayers=1
StormMinimumOnlinePlayers=0
StormMapBlocker=True
StormMapBlocker=False
"

those below are which i use.

StormEnabled=True
ElderThingsEnabled=True
ElderThingsIdleLifespan=30
SiegeElderThingsEnabled=True
StormCooldown=75.000000
StormAccumulationTime=14.000000
StormDuration=30.000000
StormDissipationTime=2.000000
StormEnduranceDrainMultiplier=1.000000
ElderThingSpawnRate=1.000000
StormTimeWeekdayStart=0100
StormTimeWeekdayEnd=2359
StormTimeWeekendStart=0100
StormTimeWeekendEnd=2359
StormMinimumOnlinePlayers=0
StormBuildingAllowed=False
StormMapBlocker=True
ElderThingSiegeDamageMultiplier=1.000000
MinimumBuildingSizeToBeSieged=41
AmbientElderThingRespawnRate=1.000000
SiegeElderThingRespawnRate=1.000000
StormBuildingDamageRateMultiplier=1.000000
MaxAmbientElderThings=200
MaxSiegeElderThings=5

Anyone found a fix for this? My server doesn’t show these settings at all.

Hi guys

We have the same issue with our non mod private server. The maelstorm settings were not touched, but in the last days it won´t start. Even the flood won´t start.
We compared the settings and everything is set as posted by @Narelle. And yet the Maelstorm won’t start and we played several hours in a row.

Does anyone have an idea what this might be due to?

Check if you have some settings that are entered twice but with different values. If you don’t have any, I would suggest deleting all storm settings from your ServerSettings.ini (the server will use the default values then) and see if this solves the issue.

We will try tomorrow. Hopefully this works.
Thank you

Edit: we´ve tried it now but its still the same :frowning: . no double entries found.

1 Like

We’re having the same problem on our G-Portal windows hosted server.
We had Maelstroms and Surges the first day, and now nothing.

The setting of the storms were changed. Reading this post, I reverted everything back to default, and made sure that no settings lines were left in the server.ini, but still, no storms or surge on the server anymore :frowning:

If anyone can help, please let me know.

1 Like

Hi…its me again
Our problem is for now solved…who knows for how long
Our solution way: re-install the game on the server and switch the settings (saved this before :wink: )

maybe its a permanent solution…hopefully

1 Like