Mod Miss Match to server screen does not show mods that need updating

Basic Info:

Platform: Steam
Issue Type: Other
Game Mode: Online Private
Server Type: PvE
Map: Exiled Lands
Server Name: NamelessOnes
Mods: Pippi.pak Emberlight.pak ArenaPier.pak GCam.pak GothicArchitecture1.pak JewelsofStygia.pak NorthernTimber.pak SandAndStone.pak Beyond_Decor.pak Beyond_Decor_II.pak Beyond_Forge.pak CreatureComforts.pak nordic_decorations.pak ExoticDecorations.pak Golden_Statues_Mod.pak Happy_Little_Trees.pak HorrorDecorations.pak Lore_items_and_roleplay.pak PLS_2.pak RavencrestCouriers.pak Savage_Steel.pak Savage_Steel_vol_II.pak SvS_Extended.pak SvS_Ext_UnlockRcpFeats.pak SvS2.pak Shanis-Stuff.pak Work_Work_Elfs.pak StylistPlus.pak BarbarianBarber.pak GrimProductions.pak HighHeels.pak immersivearmor.pak Ancient_blades.pak automatic_fish_trap.pak BetterSorcery2.pak Ultimate_Abyssal_Armour.pak King_Krampus_2.pak Kingdoms_and_Conquest.pak Exiled_lands_improved.pak ExilesExtreme.pak SerenaBadlands.pak SlaveWarsServer.pak Warrior_mutator_mod.pak WarSong.pak SeedTableV2.pak AccessoryEquipment.pak SkyeWeight3.pak AGmods_LootingAndDismelt.pak 3rdCamDist.pak KerozardsParagonLeveling.pak UIMod_Hosav.pak CombatHeal.pak Mines_of_Set.pak Ymirs_Respite.pak Ruins_of_Acheron.pak Forsaken_Tomb.pak Lost_Tomb.pak Assets_Mod.pak Lore_of_the_Lost_Exiles.pak ModControlPanel.pak Barachan_Isles.pak Sav_Dng1.pak BetterThralls.pak thralls_lvl_to_100.pak QoL.pak StacksizePlus.pak Pythagoras_Support_Beams.pak LBPR_Collision_Update_Add_On.pak UnlockableContainers.pak No_Building_Placement_Restrictions.pak MultiChar.pak


Bug Description:

When launching or continuing to connect to an online hosted server (ServerBlend and now PingPerfect), I have had continual and sporadic mod missmatch errors come up. All mods will show as “Ok”, yet they are not or they may be fine and there is no real missmatch. The only time the missmatch is correct is for a mod that needs to be added. Of Note: Mods I use are from a compiled steam collection, Yes all mods are updated for 3.0 and 3.02, yes all players have verified local files, yes server has also gone through verify process, yes we have tried deleting modlist.txt locally.


Bug Reproduction:

Launch game, or continue (online play to previously connected private hosted server), intro scene loads, attempt to join server comes up, after a while a modmissmatch screen will come up with information stating all mods are ok, selecting auto subscribe and auto connect and hit join. Modmissmatch will continue after a restart and reattempt to join the server. The screen is not displaying out of date mods properly.

@Cirsee have you tried to unsub all the mods fully quit Steam launch without mods and let Steam install them with the auto subscribe button

Yes, just now and this actually made things worse.

you’ll have to manually clear the files with the mods…something in there must be corrupted…after unsubscribing delete the MODS folder and servermodlist.txt

I have done this. So have my players, its just keeps coming back. Its a real difficult issue when your players can’t tell which mod has been updated and they need to manually fix. It needs to be addressed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.