Mod MisMatch error loop

We’re having an issue on my server where we are getting suck in a loop starting with the mod MisMatch page.
From the Mod MisMatch page, they all say “OK”, hit reconnect, restarts, and right back to the mod MisMatch page. Wash, rinse, repeat. I’ve triple checked and the mods are correct, updated and in the correct order per the server site. I have tried deleting the mod list from the files, unsubscribing from then thru Steam, reordering them and anything else I can think of.

I also noticed that when I check the 2 boxes at the bottom left, automatically subscribe/update and automatically connect, after I hit connect and it loops back, the 2 boxes are unchecked. Dunno if it means anything, but they should stay checked.

Anyone else having this issue? Anyone know of a solution?

If everyone is in a similar situation on the server, it is possible that the server has been started, but since then there has been a mod update and the server cannot update since it’s running (Mod authors are constantly updating their mods during this period so you might get multiple updates a day).
That may cause the server to have a slightly older version and your client looping since it already has the latest version but still not matching the server.

It could also be the case that you’re not getting the latest updates from Steam… even though it tells you there are no updates and you appear to have the correct stuff, if you look closer the version numbers in your launcher / ingame mods menu might not match what you would find on the mod’s page.

In that case you could try to do a verify files which might force steam to update your mods, if that doesn’t work you might have to unsubscribe and resubscribe to some of them.

If neither of these are the case then it might help if you managed to track down which mod in particular is throwing the mismatch error (maybe there’s mention of it in the logs, etc.)

1 Like

I was having it last night. I verified files in steam and then the hot-patch hit. From that point it’s all been good.

1 Like

Awesome. We finally got staggered in, but if it happened again tomorrow, I’ll definitely give these tips a try. Not sure what we did exactly, I just hept trying and eventually got in. 1 player said she had to re-install and then it was all good. Dunno, but I expected hiccups. Probably more to come too. Thanks you all for the help! :grin:


I have this problem for two days now. Every time a server has a restart, I can’t join afterwards. It doesn’t matter which server I join or which mods I have. Every time I want to join the previous server again, I get the message that my mod selection does not match that of the server, although all are displayed as status “ok” and it worked before the restart. To be honest, this function doesn’t do anything at all at the moment. Only when I unsubscribe the mods and install them again, it works. Really?

This whole thing with the mods, how they are set via the launcher and ingame is just incredibly complicated and tedious. You can say what you want about Bohemia Interactive, but their launcher, or mod management is more than uncomplicated, well connected with the Steam workshop and easy to work with. At least it shows me which mods are outdated and I have to update. Maybe Funcom should look for inspiration there.

1 Like

Any news or update about that issue?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.