Can't fix mod mismatch :(

Hey guys!

Hoping somebody here has maybe experienced similar and could help me fix it or point me in the right direction…

My BF and friends are playing on a modded server (which I have done before too) - everyone just downloads the mods from steam and connects just fine, but I just spent an hour and a half trying to get on there with absolutely no luck…

I freshly installed the game so no old mods were left, and initially just subscribed to every mod the host posted on discord - just like my BF did - hit play - mismatch.
Googled - oh, right. They gotta be in their special order. Adjusted it to exactly match the screenshot - started it up again - MiSmAtCh. Followed a guide posted on here that suggested to manually copy the “servermodlist.txt” into the mods folder and replace the modlist.txt there - still mismatch.

Deleted all mods, and told the game to download the mods when it tried to connect to the server - waited the 15 min it took to download them thru the game - it did it’s auto restart - connect - still mismatch. :flushed:

Even had my BF send me his modlist which also led to no different outcome… I’m at my wits end :upside_down_face: especially because BF and server owner both said they just downloaded the mods thru steam, hit play and could connect just fine - no sorting, no issues…

What am I missing? :upside_down_face:

The modlist from the server will have the file path on the server which will not be the list on your machine. Using the launcher to get the order correct based in the server modlist order should get you there.

As an aside, on my servers, when I change the modlist, I change my own client modlist and post the one I use in discord for people to paste who use the default game path. If you use the default path and know someone who also uses the default path, you could get them to send you their modlist and just copy and paste.


Welcome to the forums @Tantan. :sunglasses:

The game will take care of the proper order, which is why it auto restarts after it’s initial attempt to connect. The best route would be to delete all mods as well as the modlist.txt and let the game start from a clean slate instead of trying to force it manually. Mods can be frustrating sometimes, hang in there and don’t use the ‘continue’ button until after you have successfully connected at least once.

Hope this helps, best of luck to you. :slightly_smiling_face:

Yeah that’s what my boyfriend sent me as far as I know :confused:

Tried to fix the modlist order first thru the launcher, and when that didn’t work later thru the game too. What’s weird is that my BF never had to do any of that. For him it just… worked. :sweat_smile:

Yeah, once you’ve connected and chosen the server, the launcher will check all the mods. Mods on the server not installed on your client or that are not updated will be automatically downloaded and installed. The load order will be sorted by the game launcher.
Once all is done, launcher will restart and after that you’ll connect to your chosen server.

Well as davice said, complete deletion of the modlist and then one client mismatch restart should solve it. If it doesnt, I may probe you for more information… first things first tho.

Aww, thank you!

That is what I tried in the very end (or at least what I think I tried?) - closed the game, unsubscribed from all mods, deleted modlist and servermodlist file, then started the game, tried to connect, let it download all, it did it’s little automatic restart but then gave the exact same error… always using the “launch” button, since continue caused issues for me before :sweat_smile:

What bothers me is that my BF just randomly clicked the mods, launched and was fine :joy:

Something just occurred to me, if you recently had a mod update and you have an old version of the mod, you may get traction by unsubbing and resubbing that mod or simply restart your pc and when steam loads, it should get all the updated mods. The game doesnt like to update a mod when an old version has already been loaded into the client.

Maybe I made my explanation a little too complicated :sweat_smile: but it did exactly what you said, did it’s automatic restart and came back to the exact same error screen, doing the same thing over and over, restarting over and over - I didn’t even have to touch it. Like I didn’t force restart, close or touch anything initially. I just let the launcher do it’s thing like you said, but it just brings me back to the exact same mod mismatch screen :disappointed: tho the mods are the exact same everybody else is using (had 2 people watch me try everything via discord lol) and it even says Status “OK” on all in said error screen… idk what it’s still having issues with anymore

That’s a good one! A few of the mods had been installed before from a different server, I just hoped that it would update them just fine since my BF had the same mods preinstalled too and no issues… :sweat_smile: I’m stuck at my office for a little bit but gonna see if that does the trick once I’m home! :blush::crossed_fingers:t2:

I should probably add…
If you’re still getting a mod mismatch, ask the server admin to restart the server because it’s highly likely a mod has recently been updated but the server hasn’t loaded the latest version - that’s fixed with a server restart.

This is usually the case that wotannatow mentioned.

Mod mismatches tend to occur when the server and client (your PC) do not have the same mod version. Server usually the one out of date when that happens. The other way, it will show it queues up the mod update for download (although sometimes gets stuck in that stage).

My BF started about 15min before me and got on fine, and his brother just downloaded it an hour ago and also got on just fine :confused: all 3 of us being new players to the server and who havent used these mods before

Pretty sure I tried that earlier too, but I just did it again and still no change :frowning: always thru “launch”, not “continue” – keeps sending me back to the same mismatch-thing…

So just to be clear, mod mismatch at this point doesn’t let you in game at all, or its restarting once and then you get in? Is it a yuge modlist? Maybe paste the list and we can see if there’s a problem child mod.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.