Endless mod mismatch cycle

> ## Basic Info:
Platform: Steam
Issue Type: Other
Game Mode: Online Private
Server Type: PvP
Map: Custom (Savage Wilds)
Server Name: Halcyon D&D RP
Pippi - User & Server Management - v3.9.10
Sudo Exile
Tot ! Admin 0.4.1 (Alpha)
Thrall Wars Dungeon Mod
ExilesExtreme - v1.5.53
Amunets Deco Collector - v0.1.50
Amunets Dungeon Assets - v0.10.0
Northern Timber 3.0.5
Shani’s Stuff
SH - Building Kit (1.6.4)
Pythagoras: Expanded Building - v2.1.23
Barbarian Surgeon
Barbarian Barber [vers. 3.6.4]
Female New Faces
Male New Faces
Forgotten Depths [Character Customization]
Tystan’s Tattoos
Abyss - Warpaints
Immersive Armor (3.4.3)
Evils Cabinet [2.0.1]
Nocturnal Gods: Clothing and Accessories
Highmane’s Arsenal
High Heels System 3.2.5
Accessory Wardrobe 4.1.3d
RA: Character Customisation
RA: Fantasy Extension
Devious Desires
Roleplay Redux
Tot ! Chat 1.2.9
Less Building Placement Restrictions - v7.4.63
Unlock Plus 1.7.5
Stacksize Plus v1.8.3 (Compatible with all DLC and Mod items)
Halcyon D&D House Mod
Savage Wilds 1.4.43
Beyond Stations
Beyond Decor: Rustic Edition
Beyond Decor
Tot ! Immersive Hud 2.0.5c
Tot ! Custom 1.4.4
Nocturnal Gods: Warpaints
Dark Decention Barber
Legacy of Darkness: Metal & Flesh

I realize this is quite a few mods, but it is worth noting that very few (or no one else) seems to be having the issue I am having on this server.

> ## Bug Description:
I went on vacation for a bout a week and after coming back (after the June 2nd update), suddenly I found I was unable to connect to any server without encountering a mod mismatch error. This error then repeats infinitely, making me unable to ever actually connect to a private server. I was able to fix this issue (very briefly) by doing the recommended complete reinstall (removing the Conan Exiles folder from the Steam directory), unsubscribing from all mods et cetera. However, within the same breath as my issue being fixed, I suffered a fatal error in the game and, when trying to reconnect, was once again put into the infinite loading cycle. It is worth noting that this server often has users suffering fatal errors; and I have experienced many in the past. But prior to June 2nd, I was always able to get back into the server without the infinite mod mismatch loop. This server takes place on the Savage Wilds custom map. Another server I tried to play on takes place on the Odyssey D&D RP server custom map.

> ## Bug Reproduction:
Attempted to log in to a server with mods. Said server then suffers an infinite mod mismatch cycle. I have attempted this same process for other servers and have come up against the exact same issue.

Outside of going to steam workshop and clicking on unsubscribe from all and then allowing the game to subscribe to them for you when you attempt to load into the server I really do not know of any other way to fix your issue. If others are getting into the server than it is not an issue on the server side and thus it is on yours, but the best way to fix it is what I just described. However, I avoid servers with insane amounts of mods so I cannot really say what the issue is as I have no real experience with THAT many mods on one server. I just did a count, that’s 45 mods! Sadly I’ve seen servers that have had 60+.

1 Like

Yeah, it’s just odd because I have been playing on servers with this many mods (or more) for about half a year now without encountering this issue. It has only recently started to occur.

I almost wonder if it’s due to the nvidia driver update to accommodate Diablo 4, but other friends of mine who play that game have not experienced issues either. :cry:

Bumping to see if anyone else at all is struggling with this or if they might have any other advice.

I have tried other servers to no avail.

When anyone plays using mods, there are some set steps (widely documented already) that you can take when you start getting mod-mismatches (,ake backups first)

  1. Check that the server you are logging onto has any/all mods installed have been updated. If No, reacj out to the Server Admin(s).

  2. If yes, you can run the Steam File Verification on the game. Note any issues. Test if game works.

  3. If you still get the mismatch messages, get more extreme: Delete all mods from the local folder - usually in follwoing folder: :\Program Files (x86)\Steam\steamapps\workshop\content\440900

  4. Resubscribe all mods and make sure they are in the correct load order.

This should work. If you have any mods loaded that have not been updated for a while, that could be an issue and you may have to take the unpleasant step of removing mod by bod until you stop getting the error. Mak BACKUP of local game files first. You can always try asking the Admin for the Server to allow you to download the server game file to your local drive so you can try local login first.

Do a Search through this Forum for other similar issues over the past years. Also, hop over to all the mod discords and check there to see if anyone else has the issue.

Make sure you Launch and dont hit continue after double checking the list. Continue will sometimes stick with and old state.

Thank you both for your comments. Unfortunately, I have done everything that has been suggested in this thread and elsewhere (scouring the internet before I made this post).

For whatever reason, this seems to be just a me-problem and I have not been able to figure out why. I have twice managed to get into the server I intend to play on since the 5th of June with no real rhyme or reason behind the successes.

At this point, I’m just hoping the June 22nd patch destabilizes the mod-sphere enough that everything is forced to be re-calibrated and hopefully this issue just resolves itself.