Game Looping and Crashing "Disconnecting from Server" -> Mod Mismatch Crash and Restart

Game mode: Online private
Type of issue: Crash
Server type: PvP
Region: NA
Mods?: Yes
Edition: Steam

Bug Description:

Literally cannot interact with the game at all. The game loads into a message saying “Disconnecting from server” immediately followed by the mod mismatch screen which I believe is from a previous server I have tried to join. The game then crashes and restarts into the same thing. I cannot use my mouse in the game window to fix it at all, so the game is completely unplayable. I have reinstalled the game on steam multiple times, validated my files, updated drivers, and listed the mods in the correct mod order. I am very frustrated and would just like to play the game.

Installed Mods:

Savage Steel Vol. 1
Savage Steel Vol. 2
Thrall Wars Dungeon Mod
Hosav’s Custom UI
Better Thralls
Aquilonian Female
Barbarian Barber
Akuba’s Salon
RA: Character Customization
Immersive Armors
Primal Armor
High Heels System
Shadows of Skelos 2
Shadows of Skelos Extended
Exiles Extreme
Dudes Delightful Decorations
Northern Timber
Eastern Exiles
Desert Town
Ravencrest Couriers
Stacksize Plus
Shani’s Stuff
Immerse RP
Pythagoras Support Beams
Unlock Plus(with Pickup)
Less Building Placement Restrictions
Devious Desires
Custom Stats

Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. Open the game

Please help, thanks.

Do you press continue instead of launch? The game will not create a mismatch unless you are trying to connect to a server.

If you are getting disconnected most likely you get timed out by the server you are trying to join because your connection or computer is too slow to load all mods within the time limit. To help that start single player with the mods in the exact same order as on the server you are trying to join and then attempt to connect.

If you are still getting mismatch then either your order is wrong or you have a mod with a version not matching the one the server is running.

I press “Launch”, which is why I’m confused as to why it keeps loading me into that same server over and over. I cannot load into singleplayer or do anything in the game window because it is stuck on that non-interactable loop. I wonder if there was a file that told the game where to connect based on the last instance of connection to a server. I’ve been trying to find it, delete it, and have steam validate the files to restore the original version of the game, but even reinstalling did not help.

Delete your modlist.txt and try again then. Are you using Funcom’s launcher or shortcut on your desktop. The launcher one connect you to a server by pressing launch.

This is probably not your problem BUT Dude’s DD has been subsumed by Dude’s Creative Constructions (pretty sure thats the name) because DD was lost due to a cataclysmic failure. Its possible the server made the change over already… but it still shouldnt infinity loop on you.

After trying everything suggested and nothing working, I ultimately decided to completely reset my pc and redownload all applications and games, including deleting all steam and game files off the drive. This seems to have worked.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.