Infinite attempting to join Game loop

Basic Info:

Platform: Steam
Issue Type: Other
Game Mode: Online Private
Server Type: PvE
Map: Exiled Lands
Server Name: Oblivion
Mods: Pippi.pak Grim_Wonderbody_reupload.pak Emberlight.pak SlaveWarsServer.pak ThrallWarDecorations.pak Savage_Steel.pak Savage_Steel_vol_II.pak BarbarianBarber.pak Warrior_mutator_mod.pak immersivearmor.pak StylistPlus.pak GrimProductions.pak Immersion.pak DungeonMasterTools.pak StacksizePlus.pak SvS_Extended.pak BetterThralls.pak Exiled_lands_improved.pak KerozardsParagonLeveling.pak ExilesExtreme.pak ModControlPanel.pak No_Building_Placement_Restrictions.pak UnlockableContainers.pak Devious_Desires.pak Improved_Quality_of_Life.pak RA.pak RAFantasy.pak


Bug Description:

Infinite Log in loop not connecting to server, says attempting to join game, game restarts, loads mods page then closes it closes game reloads says attemppting join game, Rinse repeat… this is happening to 3 players on my server all server mods are up to date we were playing just fine last night and earlier today… given many people are having issues with this please fix it!


Bug Reproduction:

Many Many times over and over

1 Like

Same issue

Same issue here

happened to me once but I left the game restarted and it worked. Do you have a direct connect to the server ? and can you join other servers when you launch or does it go straight to joining your server ?

I fixed it cleared my 440990 folder unsubbed all mods logged out of steam then back in the loop had stopped and i was able to get on server. All good now

We are having the same issue here, private server with :

  • Greater camera distance
  • LTS compas
  • Thrall vl to 100
  • Better Thralls
  • Less building placement
  • Paragon
  • Hand craft objecy
  • Fashionists
    We tried removing all mods, log on without the internet to load a solo game but the loop starts the moment the game starts, even when not clicking on “continue” on the launcher

My users experience the SAME thing too, especially after a mod or game update.

People :slight_smile: Please do a quick search on the forums before creating a new thread with the same thing :stuck_out_tongue:
It makes it way easier for devs to notice if you’re bumping an already existing topic with a confirmation that you’re getting the same along with any additional information you can give.

Anyway, see if this helps

Posting here because in the other thread on this topic, people are under the impression that a suggested workaround of “making sure your server mods are updated” is a fix.

It is not.

These are the reproduction steps 100% Because I’ve done this about 4 times now since the launch of 3.0

  1. Install server
  2. Install mods on server
  3. Connect to server
  4. Download mods
  5. Log in and play.
  6. Log out and update the game/mods
  7. Attempt to rejoin server
  8. Mod mismatch loop
  9. Delete game.db and start at step 1 again hoping no mods update.

I have tried everything short of reinstalling the game, which seems pointless as others have already done so and thats not going to fix whatever is happening “under the hood” of the game with mods.

No, in the other thread people were trying to help you and you were being unnecessarily arrogant by not trying any of the listed steps and instead boasting about how many years have you been running a server for. You deleted your post before I sent my reply though, so I did the same :slight_smile:

Here’s the thing… like I pointed out Steam is having an issue currently… and it’s not pushing out updates of the workshop… it will tell you that there are no updates… even though your files are not updated so I do not see how your years of experience in running servers helps you in the current situation - spoiler: it doesn’t.
That’s why it’s been suggested that you make absolutely certain you have all the latest versions of everything. On top of that there are still a lot of updates almost daily from mod authors since they didn’t have time to prepare for this update so what you updated yesterday might not be up to date today.

And yes the loop keeps happening even after you update your server, because the clients are also not getting workshop updates pushed to them, for those the steps listed in that other thread fix the issue.
The post I linked to above contains the actual steps… including what files to delete and what to do afterwards.

2 Likes

Not arrogant. Frustrated. Not boasting, informing. Theres a difference.

I deleted a post because I just put an edit on my reply instead.

I have indeed done your steps, multiple times to the letter. I have gone further and manually moved my mods to the server (which is a 100% match) and I have also moved server mods to my machine as well.

No Joy.

Always a mod mismatch. The game works on the first install, the moment you log out and or update a mod, everything comes crashing down.

That I know for sure, like I said, I spent all day yesterday re-installing servers and mods and starting new games and the end result was always the same.

Alright, fair enough!

Have you changed anything in your mods since the update? like dropped some of them that are old or got new ones etc?.
You could try deleting your modcontroller cache on both the client and the server to make sure they get recreated and match. It’s in the Saved folder next to your databases ModControllerCache.json do it on the server first, take it down, delete the file and restart it. It should recreate the file.
Then delete it on the client too (same location, Saved folder) try to start your client, make sure all your mods are loaded in the same order and go into single-player first just in case, then try to connect to your server.
Even if you still get the loop, the steps from the other thread might work after this.

same again and again and endless

No dropped mods.

Fresh server install, fresh mod install on server (either via SteamCMD or manual upload/download).

I did try removing modcontroller cache from both the client and server. No joy.

You can play the game until you log out and or a mod updates. After that, its the endless mod mismatch loop.

The workaround you posted might provide temporary relief for some people. But the issue will still compound eventually and it’ll be back to square one.

Yea ofc. It is only meant to be temporary so people can get in and play in the meantime at the cost of a bit of extra effort.

I really don’t expect people to play like this forever, however if you scroll up in that other thread you’ll see some replies from @Mayra too. So the developers are aware there are issues with the game and workshop and I’m sure they’re trying to solve it.

In the meantime though, these extra steps can help people play the game. That’s all I’ve been trying to help with

I’m having the same issue. Deleting the servermodlist and modlist files, verifying the integrity of gamefiles after unsubbing to all mods helped the first time.

This time I did the same thing and got an error saying that the game failed to launch. Over, and over, and over. Verifying, restarting steam, opening up the exe directly through the directory didn’t help. So now I am doing a fresh install, no mods subscribed to and I’ll see if it happens again.

All I know is that I just bought this game on a new steam account, I JUST paid for the pass, and I can’t even play it. Of course, I can’t request a refund on the pass either: Something I paid for but so far, can’t use. I think the constant endless loop corrupted all of my files and eventually the game wouldn’t even launch.


This is what I got after getting the endless loop, unsubbed from mods, verified integrity. The game wouldn’t even launch.

1 Like

I play on a private server and for the moment with only 2 mods (Pippi and Savage wilds) who seem to be stable. All the other 33 mods we are waiting for them to be properly updated to use them so we’re playing vanilla for now to discover the new stuff… mods are too unstable at the moment for the reason @Xevyr pointed out.

Was it a permanent fix? Ive tried the mod resub and deleting the modlist. every time its just been a temporary fix and logging out rejumbles the mods

On PC - Attempting to connect runs for a long time, then the program closes, then auto starts plays the video then starts back at attempting to load. Rinse and repeat until I stop it by restarting the system.

I should also say that this is with fresh installs of all mods. associated with the server.