Multihome on query protocol STILL BROKEN

Game mode: Online Private
Type of issue: Bug / Crash
Server type: All
Region: All

Windows dedicated server multihome for query protocol it’s broken, query listen on all machine IP’s and not on the one defined on multihome switch.

Also querying the server from steam makes the server crash, you can find a proven GIF here:

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Define secondary IP for server and start it
  2. Check ports on CPORTS.exe query port, not multihome
  3. Query server on Steam watch crash

Last update fixed the crashes on querying, but multi home still broken, servers do not support multi home on query protocol yet.

Query port listens on all IP’s:


My server is bouncing frequently as well, and crashes often during play. This started after the last update, and appears to have gotten worse after the hotfix. It has become so frequent that the game has become unplayable.

I just communicated with my host, and they provided this information. I am going to try their workaround until this is fixed.

10 updates later and query port still not binding to IP:

just wow

My Multihome setting is binding to a local IP.

Try unchecking saving then reapplying the setting?

Annotation 2020-06-29 220300

I’m finding I’m not having the same issue.

However a friend has reported she is reporting the same issue and I’m keen to play on her server again. So it’d be good to find what’s causing the MULTIHOME Mode binding to fail for some people and not others.

Here is a useful like to what @Multigun did to fix his connection issues when running his client on the same machine as his server: Failed to login (while dedicated server is running) @Multigun

Just tried with that tool on my home pc and on a VPS, broken:

This is still an issue for our server hoster “Dawn-Server”. Is there a fix in the pipeline?

Hi @Thyris, we have several fixes in the pipeline, however, the server hoster should reach out to us directly as others have so that we can determine if it’s a known issue or not.

1 Like

Thanks @Hugo for your answer. I’ll provide a link to this thread to my provider.

1 Like

Hi Hugo.

Nils here from myLoc managed IT / dawn-server
Thank you for reaching out. I would appreciate a DM or any other way to contact you about this issue. In short the server currently does not seem to bind the query UDP port to the IP specified with multihome. Instead it binds to This is a big problem with our current setup, especially with Windows.

Thank you!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.