No concussive damage bars show up on NPCs; they die instead of being knocked out, and I can't make any thralls :(

, ,

Game mode: [ Single-player & Co-op ]
Type of issue: [ Bug ]
Server type: [ PvE ]
Region: [ USA ]
Hardware: [ PS4 Pro ]


Bug Description:

None of the human NPCs have a concussive damage bar (the smaller blue bar above their HP bar). They only have the red health bar. Any blunt attacks with any blunt weapon only do physical damage and don’t seem to register any concussive damage whatsoever. Because of this, I can’t knock any NPCs unconscious and tie them up, and I’m not able to make them into thralls.


Steps to Reproduce:

  1. Select Singleplayer/Coop from menu.
  2. Enable or disable coop, and start or continue game.
  3. Encounter any human NPC (archer, carpenter, named, unnamed, armorer, anybody else, etc.)
  4. Attack the NPC with a blunt weapon (i.e. blunted javelin or truncheon)
  5. The NPC only receives physical health damage, and no concussive damage is shown.
  6. The NPC dies from repeated attacks and does not fall unconscious.
2 Likes

Es kommt auf die keule an.
Die holzkeule hilft gegen “normale”
Wenn du namhafte thralls betäuben möchtest brauchst du Eisen oder stahl keule damit sie nicht sterben

Welcome to the Forum. This problem has been run into before. My wife and I have had it a long time ago. If I remember right it was something in setting. Have you changed any of your settings? I am not home so can not go in and check. Being as you are playing offline admin your self a reinforced truncheon put a advanced blunt weapon fitting on it and see if it helps. If you have increased your damage or decreased npc damage that could cause npc demise over concussion. Good luck :+1:.

1 Like

This doesn’t seem to matter. I don’t get any concussive damage bar for any NPC, regardless of what type of truncheon or blunt weapon I use.

This doesn’t seem to help. The damage multiplier settings are all at a default (1) multiplier. I am still not seeing any concussive damage bars on NPCs no matter what blunt weapon I use.

1 Like

I am online now let me check settings.

1 Like

I looked at the settings on my server and a offline game knock out works on both. When we had the problem you have I believe it was something we did don’t know many offline players will send to @Croms_Faithful and @Community and @CodeMage perhaps one of them can help also I appreciate any help that you good people can give.

1 Like

@Wak4863 sorry you were on the tail end but someone had to be appreciate everything you do.

This issue has sprung up a couple of times since the games release. Sorry to be unhelpful sestus2009 and @magenta, but I have not had the misfortune of encountering this bug yet. And sadly I can offer only very simplistic suggestions on this one. I would recommend:

  • discard your existing truncheon and blunted javellins and build new one(s)
  • try out all of the different tiers of truncheon, ie-wooden, iron, steel
  • try both with and also without concussion fittings and oil
  • try both with and without Strength perk 1: thuggery
  • try blunted arrows with your Bow also

@magenta play around with a few of these variables and see if any of them do the trick. Sorry I cant be of more help guys.

By chance are you using a shield when trying to knock out NPCs. Combos that use shield bash can and will damage opponents and all concussive damage items do a small amount of physical damage as well. Maybe, if you are using a shield, between the two, they are causing enough physical damage to kill, if they are a low-level NPC.

Also, I didn’t see if anyone asked if you’re using any mods.

I’m not using a shield or mods.

It’s not so much the issue of the blunt weapons causing too much damage; I’m more concerned that I’m not even seeing any NPC concussive damage bars at all (the tiny blue bar that’s supposed to show up above their red HP bar).

1 Like

Hopefully when the Funcom crew comes in tomorrow they will have a answer I know this isn’t the first time it’s happened wish we could help. How about starting another offline game and see what happens :thinking:.

Looks like most of stuff was covered. I rarely change most of modifiers, outside player damage ( to 2.0)

I tend to admin panel myself reinforced truncheon, advance blunt fitting. With 1st perk from Str havnt had much issue. I rarely use alot of other weapons(or legendary ones, since few bugged out,get patched…bug out…)

My encounters with glitch have been down to 2 things. (3rd being fully broken patch breaking it)(Not having issue on Ps4 or PC on latest patch)

-1 One of Weapons is goof’d and trying another usually works.
-2 Damage Setting is off.
(on 2.0, they often Ko just before dieing… small window for screw ups)

I guess the 4th would be something in Setting, was change on how Names/Health Display was change.
I only ever turn off rotating afk camera and contextual controls. And turn back on Hot keys.

Never messed with HP bars.

1 Like

Hey @magenta has the issue been resolved yet? If not, I have a couple of additional possibilities we could try out. Ok we will try the one I feel would be our best hope first: restoring everything to default.

  • bring up the menu with the ‘Options’ button > go to ‘Settings’ > go across to ‘Server Settings’ > in General , press X on the Make Me Admin option. Now notice how the config down the bottom of the screen has □ restore defaults? Go ahead and restore defaults in ALL (just to be on the safe side) of the Server Settings sub-menus (eg-Generl, Progression, etc), then also in the regular ‘Settings’ menu which preceeded Server Settings. In either order if you would like.

See if that does the trick, and let us know if it works ok?

Ps- just bear in mind that this will be resetting the ‘drop equipment on death’ status to ‘on’ again (checked), so just be careful to uncheck it again before you head back into combat, if that is your playstyle.

3 Likes

Setting every settings tab back to Default worked! I can see the concussive bars again and knock out NPCS! Hurray!

The solution doesn’t really make a lot of sense, though, because the combat damage multipliers were unchanged. Maybe it’s because I had turned the music volume down…? /s

Anyway, I’m so glad I tried this before giving up, starting over and losing my saved game. Big thanks @Croms_Faithful!!

2 Likes

Hooraah!! I am so happy for you @magenta! And it made me very happy to read that it worked. If I could I would fire a couple of six shooters into the a few times in celebration, rich Texan style.

I am at least 99% sure that it is not the Damage Multiplier setting, as it is one both myself and other members use often to cut down the battle time on some of the World Bosses who have massive hp pools. So it is common for members to bump it up to 3.0 or even 4.0. That and the Drop Equipment On Death setting and the admin teleport option are all safe from my own experiences. The lack of concussion damage seems to be tied to one of the other settings, but I am not sure which one, and I would only be offering pure speculation.

There are a couple of other settings in the admin panel which we know what they do that may be of benefit to you and improve your quality of life a bit as a Singleplayer, such as reducing the breaking time for Thralls on the Wheel of Pain, and how to maximise your chances of getting a human Purge if you are intereted? If not no worries, happy gaming there; and you can always come back to the aforementioned solution again if something goes wrong again.

Yeah me too Magenta, and this speaks credit to your character to for that matter. Too many people in this day and age would have raged out and gave up. It was my absolute pleasure to help you out, and the community members here on the forum are always eager to help where we can. Bugger there doesn’t seem to be a ‘Solution’ button here in these bug report threads, but meh. It felt good to actually help someone resolve an issue again! Happy gaming there @magenta! :smiling_imp: :metal:

2 Likes

I knew it was something in our settings when my wife and I were playing we likely had no idea what we did to fix it I am really glad to see you back in the game. @Croms_Faithful I thought you would have a educated guess you might be the one who helped us out back then.

2 Likes

In the interests of being a man of honesty here sestus2009, it may not have been me. Because I have seen this topic previously, but was not really sure what to do. I just spotted it while having a regular old game the other night, and it came to me pretty much on a whim. But I am really glad it has been sorted out…for both of you!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.