Noob Player Stuck at Tutorial

I just recently joined this game and I really wanted to love it, but so far it has not given me a good experience. I’m still stuck with the tutorial after playing for two hours in total, and at this point I’m beginning to think that this might not be a game for me after all.

Yesterday I played the tutorial to the point where I had to fight the Ravening Revenant in the graveyard. I tried for like half an hour to beat it but lost every time. Then I decided to quit for the day and try again the next. So today I logged in again, only to find that the Revenant is not there anymore. Instead the game tells me to collect the lever from the Gravekeeper’s body again, but there’s no Gravekeeper or his corpse either. There are a couple of corpses lying about, but they have nothing on them, and nothing at all happens no matter what I do. It seems like I got stuck at the tutorial somehow when I logged out.

So what do I do now to get the mission progressing again? Or should I just give up the game now? I have played other MMO’s, and I know I kind of suck at combat compared to average players, but no other game has given me so much grief during the walkthrough mission.

If you’re having an issue in-game, you should /petition and report the issue to a Gamemaster. In cases like these where a mission flag isn’t working properly they can reset it very quickly after the issue is explained.

As far as fighting the Revenant in the graveyard, it’s part of the tutorial that is teaching how important it is to avoid highlighted areas of enemies attacks. As long as you stay out of the Revenant’s AoE attacks (dodge is useful for this), you should be able to defeat them.

Welcome to the game. It looks like you may be on this part of the tutorial, 15:05 in the video.

If you missed something or something is bugged, it may be quicker to just delete/start a new character. The game is well worth playing, but I am one of those people that need to view guides on and other sites.

Hmm, that revenant fight should almost impossible to lose if you get out of his big telegraphed AoE attack on time. You need to watch the indicators on the ground for that.

If you didn’t run into some weird bug, but actually kept dying due to the fight’s mechanics, quite honestly, SWL-style combat may be so much not your thing I’d question whether you could enjoy the game. “Watch ground indicators, get out of telegraphed attacks” is very much a core mechanic.

If you think you ran into a bug, try again. Given the game is essentially on life support, filing an in-game ticket via ‘/petition’ could take a while to get your current character back on track, so I’m seconding @Nikolai’s suggestion to delete/restart.

Well, looking at that video it seems my character isn’t dodging either. I tried the shift/direction thing, and the character does move, but like running in a normal way, it doesn’t seem to do any jumping or rolling on the ground like in the video. Which I suppose is a big factor why I can’t beat the thing.

I will give it a few days and then perhaps try again. I will have to check my controls too, and see if I can make the toon dodge at all, perhaps with double tapping, and then make a petition or restart.

I have done that fight against the revenant multiple times (I have too many alts, okay?) , and I never bother with the dodging maneuver - I just move normally out of the attack.

Unless you have severe lag or have run into some bug, it really should not be difficult to avoid the revenant’s big attack. When you first play the game it may take some tries to learn the controls, and to get a feeling for the timing needed, but it is not supposed to be a hard fight.

Double tapping a direction should also dodge if shift+ isn’t working for you.

If shift doesn’t work you may check in settings if it’s allowed to. Also you can rebind it from shift to something else.


Not to be rude,but seriously if you cant get past that tutorialfight…this is not the game for you…

Just to save you some frustration later on :confused:

I logged back in, and the game had unstuck itself, so I could proceed the Revenant fight without petitions or deletions. I managed to beat the thing, just barely. I still can’t make the toon dodge no matter what I do, so I hope it’s not an essential mechanic. I can still run out of the way of the AoE attacks most times. I played the rest of the tutorials up until Agartha without any additional problems, next stop will be Solomon Island I think.

I’m a little concerned how hard it’s going to get if everyone else here considers the Revenant a pushover, because it still was not an easy fight for me. I admit that I’m very bad at games that require lightning fast reflexes, coordination and precision, such as 1st person shooters. Still, so far so good so I’ll see what’s around the corner in the coming days.

It pretty much is. Well, not the dodging as such, but the getting out of big telegraphed attacks by either dodging or moving fast enough. Given it sounds like both are giving you trouble, some fights will be immensely unfun for you.

Oh, and you’re probably going to hate many Sabotage missions, too.

You will need to dodge things, but you’ll get better as you go, just might be some dying here and there at the start.
It’s weird that the dodge function isn’t working for you though, either shift and a direction key, or double tapping it quickly should let you dodge/roll out of attacks.

I hope you have fun though, and enjoy the story

I think the tutorial can put a lot of new players off and perhaps they should remove it, make it optional or at a later stage in the game once you are in the world. If you want to just kill stuff and grind mobs, you can do that, but I still rely on 3rd party sites to figure out most of the quests.

You can also enable double tap dodging.

ESC > Interface Option > Combat Tab > Enable double tapping to active dodge.

I prefer to bind dodge to my space bar and use Alt to jump.

Double tap should be enabled by default. Always the first thing I switch off (personal preference).


I managed to get the dodging to work. Not sure why double tapping wasn’t working earlier, but it’s working now. Shift works too, but it took me a while to figure out that I have to press direction first and shift second, and it doesn’t work the other way around. Double tapping might be easier for me to use if I have to do it quickly.

It’s probably just taking me a while getting used to the controls. Kingsmouth has been good fun so far. It may be that the Revenat fight comes too quickly for some new players who are just trying to figure out what the hell they just logged into. The FPS rate of this game is not good, but it doesn’t prevent me from playing, just painful looking at times. Agartha especially looked very choppy.