NPC Camps won't spawn NPCs (Single Player only)

Game mode: [Single-player]
Game patch: [2.3]
Type of issue: [Bug]
Map type: [Isle of Siptah]
Server type: [PvE]
Region: [North America] (I believe @Narelle is in a European time zone, and thus, is affected, too. So this problem may not be affecting just the North American region)


[NPC camps (such as the Accursed Citadel) won’t spawn human NPCs]


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Go to the Accursed Citadel
  2. Camp is empty (except for monsters)

At first, I thought this was a mod issue. I asked @Multigun to help investigate. He was seeing the same thing without his Thrall spawn mod. Then tried again with no mods and the problem still persisted. So it affects the map both with and without mods.

Later, @Narelle graciously tried to investigate it, too. @Narelle reported that on the server, it worked fine (NPCs camps were populating), but in single player, NPC camps were empty.

We all tried teleporting away and back again to get the system to reload the camps. That did not work for any of us.

@Narelle also tested this issue in single player on Testlive, and the problem was there as well. So this problem seems to affect single player only.

Indeed, I can confirm the issue on the current Live version. I did the test before the 2.4 patch, so I will need to re-test there because I know there were some optimizations done with that patch.

1 Like

The problem still persists in patch 2.4 on Testlive. :frowning:

Update: Okay, now after being in the area for a while (ten minutes or so… I wasn’t expected any changes, so I didn’t watch the clock)… the camp started to populate. So maybe its just a very slow camp load or an intermittent problem. Either way, NPCs eventually DID start to show up and populate the camps like normal. So maybe its a ‘load priority’ issue?

My computer system is fairly beefy, so that’s very unusual (its not a hardware issue). I’m running an Nvidia GTX 3070 with 32 gb ram.

1 Like

And as a follow-up, with patch 2.4, the new NPC camps spawn just fine. Its the big camps like the Accursed Citadel and the Stygians that are empty for a long, long time.

Smaller NPC camps are hit and miss. A few of the NPC camps at broken leyshrines are empty, but a few of the outer camps seem to spawn NPCs like they should.

And this is single player only. No server. No co-op players. Just single player mode.

On the Exiled Lands there are some camps that are unpopulated for the first couple of minutes. For example I live nex to Fleshtearer Falls, for the first minutes it is completely empty. All other smaller exile/darfari camps, caves (the spider cave where you can find the Nemedian helmet, I forgot its name) are fine in the area.