Official server 90% loaded then kicked back to main menu

xbox

#1

I try to join an official server that I’ve been playing on since the game was finally released and shortly after the last update, I got kicked and couldn’t rejoin. I tried resetting everything from my router, Xbox and modem and still nothing. I swapped my game from my external hard drive to the internal and that worked. Now its happening again so I followed the same steps and still nothing. I uninstalled it and reinstalled it and still nothing. I’m all out of options at this point.


#2

Same issue with xbox 2502 keeps losing connection to host and I have reset everything it’s been 15 hours


#3

mine has been like this since yesterday. I don’t know what to do anymore. I love the game but I can’t play it :confused:


#4

Same here I can connect to all other servers just not the one I play on


#5

My friends can connect to my server but I can’t. this happened to an old clan leader too but we were all able to join the same server.


#6

Yup same here it sucks


#7

worst part is that I’m the only one in my clan so if I don’t login for X amount of time, my base becomes destructible to anyone who comes across it…


#8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.