[Other] My Xp just stacks without leveling me

I saved my XP for a few days while running at 25% research. When I enabled it today and used insurance agent it did not level me. As it is right now I am at level 199 with XP 259,420,167 / 73,393,900. The game should have levelled up my toon. The name of the toon is StigmataTra2.

This could be a crash bug (relog) or could be because of the level prompt you get at level 200, this is also where you start getting SK instead of XP. So you might need to accept the level prompt and go kill something :slight_smile:

I never got the level prompt. If I had and could accept I don’t think I would have the problems I have. I will log on and do some dailies while turning XP on and off and see if it helps.

Edit: I did try to kill stuff and do dailies with XP on and off but it just adds to my pot. before I died in Inferno earlier I was at 500m/73m.

looks like you have "Disable XP Gain (research still active) checked under F10>Character

No, I do not. My XP would not be displayed as higher than what is required to level up if it was checked. Current XP is at 376,452,753/73,393,900 plus I have some in the pot also.

I know someone with an old ARK account had the same issue once, they couldnt level past 200. I think you might just have to send in a petition to get this solved.

ok, so it seem you have char issue. And as Nave wrote above, i remember also such bug that somone solved with ARK, because he couldn’t level past 200.

I did write a petition a few days ago. I hope somebody will see it and fix it.