Over Active Target Lock

Okay so my target lock is (and has been since they added it) way to over active. It’s driving me nutz. Volt over a rock: target lock, Climb a wall: target lock, Do an emote: target lock, Use the dang cinematic (vanity) camera!!: Target lock. I keep getting told to ether “get good” (not helpful), “Learn to use it in combat” (not what I’m talking about), and “Just turn it off in setting”.

I have looked in the settings and I don’t see it. Other people I have talked to in game say it doesn’t happen for them in the first place (??? Why me then). All I want is a straight answer.

How do I turn it off???

1 Like

I have the exact same problem. Turning it on or off in the settings has no effect.

Under keybindings>toggle target lock, try setting a key then use it to turn it off. Also turn off auto-face as it seems tied to target lock.

Auto face is off and target lock still auto locks on and faces me in the direction every time. I know how turn it off after it has come up. The problem is it coming up. I wave at someone and lock on to a passing rabbit facing and following it like a dufis.

1 Like

What is your toggle target lock key?

I’m having the exact problem. When I zoom out to 3rd person from 1st, target lock enables. (Turning off autofacing simply keeps you from losing focus when it toggles on.)

When I’m fighting a boss and I switch weapons, I need to face away from the threat or my target lock will auto-acquire every time. I DON’T use it and have the Q key set by default, and am constantly toggling it off. I also would like to disable it until whatever has been done is undone.

1 Like

Toggle target lock key is Q. It only disables it for that particular instance of target locking. If I pull out a repair hammer, or climb somewhere, or use an emote seconds after that, the target lock engages again. So no, looking at target lock toggle isn’t helpful. There needs to be a solution in the game settings.

timrath What he said

I dug into the *.ini files and found this line:
The same line repeats 3 times within that file for some reason, but they’re all identical. But if everything is set to False, then why does TargetLock still engage?

I had the same issues. Though disable target lock and auto facing solved it for me. I also enabled first person when weapon is drawn. Maybe that also has an effect…

1 Like

It just means that the modifiers are not specified. So the engine will perform the action only when pressing Q instead of CTRL + ALT + Q.

1 Like

I don’t even have an option to disable target lock at all. I can check/uncheck auto facing, allow first person in combat and a bunch of other options, but I don’t see target lock in gameplay or controls. There’s just an option in keybindings. How did you disable it?

1 Like

I can double check when I am home from work in approx. 2 hours

Target lock is under keybinds. I set the default key to F12, and disabled it, and turned off auto face also, when these options first came out, and its never been an issue since. To be more specific, I play in third person mode always, and never use first person. I think 1st person, target lock, and auto-face are somehow tied in with each other, but that’s just a theory.

How does one disable a keybind?

These are my settings for gameplay and keybinds. I dont use first person at all, and have never had the issue of auto-face and/or target lock you speak of.



My auto facing is off and it still locks on and auto faces me to it. My key binding is “Q” and their is no turning it off. I can cancel a lock-on after it already has locked-on but I can’t stop it from locking on in the first place. Everything I do short of breathing seems to trigger an target lock on something. Even pulling out a tool triggers it. I need it to stop.

Assign the Q key to something else.

But what you describe is more that happened to me. Your game is rigged :stuck_out_tongue:

I see now, there are two solutions:

  1. Either stick to 3rd person camera always, or
  2. allow 1st Person Camera in Combat.
    Both of these are unsatisfactory. I was hoping that I could continue to play in 1st person mode, with the game only switching to 3rd person when I’m in combat.