PC Crashes in In-Game Menu System & Wierd Behavior That May Be A Symptom


Unless my computer is the only one still doing this, it looks like there is still the issue where the PC game slows down and crashes during game play when in the in-game menu system. Whenever I go into the menu system I see the game slow to a crawl then seem to freeze. Sometimes the game dumps. Basically the same thing a lot of other players report.

For details I’m running the latest Steam version on an AMD FX machine. I’ve also tried the AMD beta fix. Didn’t help. I’ll post more specific details later. The point of this post are the interesting things I’ve seen the menu system do. I don’t know if these details have been noticed, by the players or the coders, and I haven’t seen them specifically get reported. Maybe the details can point to what might be causing the issues.

I’ve noticed that the issues really only occur when you trigger something in the menu. I can move my cursor around the map all I want but as soon as something in the map is triggered, when something changes, that’s when the issue occurs. The same thing goes when I hit a control or one of the roll-over buttons or graphics. Bang, the game starts to slow then freezes. Here’s the second detail: Rather than killing the game when it freezes I’ve tried to back out of the menu and then left it alone to churn along. About 1/3 of the time it will respond eventually to an ESC back out, maybe after 2 minutes and maybe 15-20, and eventually drop back into the game which then runs fine, or if I hit ESC a few times during the “freeze” it drops out through the game to the next menu one level down (save/quit/etc). Finally, three time now I’ve also seen it do something REALLY weird. Dropping back into the game it came back to the scenery but my party wasn’t there. It showed a section of the map I wasn’t on with pointers TO BOTH of my party members. It would show this for a random time, I think based on how slow the game had gotten, then it would eventually switch back to the terrain where I actually was, find my party, and I could continue on.

I don’t know if these details will help or not. Maybe you’ve already seen them or recognize as being part of the problem you are already working on. To me though they point to a few potential issues that, given my admittedly limited coding experience, I could see causing the problem: trigger issues, layer issues, or interactions between the menu and the game still running in the background. Maybe:

  1. The background game is not properly disengaging when you are in the menu system. It is still playing in the background and causing load issues. Worse, it might be reacting to the menu system triggers at the same time the menu is, causing in-world actions. I think I’ve come back into the game and seen my characters in slightly different standing configurations from when I went into the menu. Even if this isn’t happening, it still seems like it’s your triggers and interactions in game sub-systems causing the issue, the same way some of the in-game videos also trigger the slowdown and freeze.

  2. There may be a massive layer issue in the Map menu, where the in game location is traveling along with the cursor position on the menu map. That would explain why the game would drop back in to a place none of my characters were. Or maybe it’s happening on some or all of the other menus and the “float” is less and takes less time to reset. But I’ve only seen the extreme dislocation to another area of the map coming back from the Map menu.

Anyhow, I don’t know if this will help or not but I figure it’s more productive than screaming “Help, my copy of the game doesn’t work.” Anyone else out there seen any anomalous issues that might point to the root cause of all of this?

Hello @Briar, welcome to the community and thank you for sharing such thorough information!

A new patch is being released today that addresses a multitude of performance issues and crashes, could you please let us now if it mitigates the problems you’re currently facing?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.