PC - Equip Light Armor Bug

quest
pc

#21

Same issue here, xb1 pve, english


#22

English official here.


#23

Same here… Still doesn’t work 18 days later!

PC Player.


#24

same here every server i enter i found the same problem and i tried everything stil doesnt work
PC user


#25

Donning a sandstorm mask seems to work for some people.


#26

Sandstorm mask doesn’t work in our server, fun fact that this worked in other server i played


#27

Hello,

I solved the problem for French client users. Launch the client, go into setting, gameplay and change the language in English. Log in and you will have validation.


#28

German, switching language also doesn’t work. (And btw. when using German, we still have no weather.)


#29

We had this same issue on the Official PvE-C server. When they were shut down, I started our own private server, this issue didn’t happen to us on our own server, everyone was able to get the journey.

Our server is a dedicated Windows 2012 Server which just hosts the game, not used for anything else.
Our server is setup for English, not sure if that’s relevant.


#30

I have the same issue and i am wondering if you are going to fix this.
Its pretty sh*t because i want to do journey but i cant see tier IV until i got the light armor journey form tier III.
Would love to go on with journey.
Thank you


#31

What continent?


#32

Hello,
I solved the problem for Spanish client users. Launch the client, go into setting, gameplay and changed the language in English. Log in , equiped a piece of light armour and i had validation.


#33

Its set as an EU server in the server list, but is physically in England.


#34

I was trying to equip the light armor (light tuban 52001, light tunic…) but it didn’t work. Then I crafted serveral different types of armor (defari light armor, derketo acolyte robe…even some heavy armor, just in case). Didn’t work either. That was the problem during the early acces phase, even on testlive, and it still remains while I’m playing now with the official release version as a solo-game, as well as on a rented private server. I tried to switch from the german client to the english one, which doesn’t seems to work for me, at least not on the private server. In order to sort out which armor types would work or wouldn’t, I just tried to cheat a bunch of them through the admin-panel on my solo-game (made a new charakter, who still wore the coarse armor / with english client set). The first item (light turban 52001) was automatically equiped, what triggered the journal entry. So I tried the same thing for my character on the private server…aaaaand it didn’t work… [A friend of mine has the same Problem, also on PC, but with drastically different pc specs]

PS: I will try to switch the server settings to english to see what will happen.


#35

I had this bug until few days ago i switch my solo game in english and equip the sand storm mask and it worked for me. Then i go back to french. I get the sand storm mask from the admin panel.


#36

German here doesnt work too.


#37

Switching the language in official server from english to french to spanish to back to english didn’t help.
Too bad this fix didn’t came into patch.


#38

In my case switching server “culture” in G-portal panel to english worked. I had “de” set by default and equpping light armor didn’t trigger journey step. Then I switched to “pl” (my native) and restared server - didn’t work. But after this I switched it to “en”, restarted - and boom! It worked! :smiley:
So it looks that switching a “server” language matter, not the game’s client.

I also play with english language set in game, but I’ve tried “de” and “es” too when “culture” on server was set to “pl”.


#39
  • Game mode: PVE - official #2011Problem:
    Same here light armour won’t complete…in English language. Made armour,wore alll light armour Inc dafari, still won’t complete…and can’t see further journey options. I also threw a gas orb…and that also has not completed.

Shade Darklight.


#40

Same here. I made a Light cheest and Darfari chest to test and still don’t have the step.