PC - Equip Light Armor Bug

quest
pc

#1

Hi! I’m using PC version of the game and when I equip a light armor peace, it doesn’t complete the “Equip a peace of Light Armor” quest.


Equip LightWeight armor Journey
#2

I play solo in pc. I have same problem. I make light armor piece i repair light armor piece and i equip light armour piece. Quest doesnt change.


#3

Similar thing happens in Xbox with the Upgrade a Building Piece task.


#4

Yup, same error here. Playing on PC, online running a hosted server.


#5

It is still not fixed and very annoying


#6

It’s working on single player, so I guess it’s just affecting dedicated servers.


#7

Game mode: Official PVE
Problem: Bug

I think this bug it’s here for quite some time, when you equip some light armor, that journey quest doesn’t update. What is happening? Why are ou taking so long to fix this?
And another problem that is happening is that when we log out and log in there’s a reset on all journeys and then we can’t finish then again.


#8

I can confirm this. At least the “Equip light armor” journey entry issue.


#9

Hi all, this is a known issue! Please try different types of light armor and see if that works.

Also, what specific armor(s) are you all trying to equip? I’d like to see if there’s any pattern to it.


#10

Working just fine for me…


#11

Is coarse armor supposed to count? I also tried basic light armor from hides (first what you unlock).


#12

I’m having the same problem, I have equipped every piece of the basic light armor and it doesn’t work.


#13

Also the Darfari watcher mask doesn’t work either.


#14

i tried a full light armour set and i still dont have the journey achivement. i did equip the Royal armour before i tried light armour, but other than that i dont know


#15

Same problem for me. Although it works for me on the official servers, it doesn’t work when i play solo or on our server rented at g-portal


#16

Hey all, for those who are running into this issue, what language is your client in? Just following a lead.

Also, I don’t believe coarse armor is supposed to count @Sonnyslav.


#17

For me french i play in single player


#18

It worked for me when I did put light chest piece. But a friend of mine did not have my luck and wans’t able to complete the quest. We play in portuguese. We play in official servers.


#19

English official here.


#20

Hm, okay, bummer. I was following a possible lead that the language of your client could cause it (based on another player’s recommendation) but I’m not sure if that’s the case if you’re also in English, @Sonnyslav. We’re looking into this.