PC XBOX Game Pass doesn't have Sorcery update. Can no longer play the game

Got the game on my PC through Game Pass and had a lot of fun. Was looking forward to the Age of Sorcery update, but it never came. The Xbox app changed the title picture and other media on the page to confirm that the update was here, but no update. I can load the game but can’t play on my server anymore. I checked for updates, uninstalled and reinstalled and no luck. I was wondering when the update will reach the PC gamepass version or if I should cut my losses and buy it on steam.


yeah same problem here , hope Microsoft see the post

I heard of this happening before. theres a quick fix.

usually if you uninstall the game and reinstall, it helps.

if it still isnt fixed.

try not building around horse spawns.

There was one thread on xbox forums, but the OP was told to contact Funcom forums, so here I am.

nope sadly, if you delete and reinstall, gamepass right now gives you conan build 403075/34529, which IS a 3.0 updated build that was released yesterday for gamepass, but not the one that’s needed in order to connect to any server. ( needs to be build 408113/34671, which Steam has )

And they no one telling us when this will be fix or why this has happend.

perso j’ai reinstaller le jeu et j’ai reussi a avoir les nouveautés de la maj mais ce n’est pas le seul probleme dans les serveurs il y a que 1 serveur qui est nommé “Win10_PC_CERT”

So If I can’t login to my server I’ll just lose everything ?

I have removes game from Xbox and installed it again the new version 3.0 looks like it’s there but when you try to search for server the lobby is empty. Game only works on steam but I can’t move my character to that platform. I don’t want to start game from beginning. What’s going on? Why no update on xbox pc game pass?

Microsoft is throttling deployment of the update on their platform for some reason. They’re rolling it out in waves of people, but it’s taking a very long time.

This is ridiculous that we haven’t gotten this update. It’s a holiday weekend and instead of playing the game like I had intended, I can’t even play at all. I have so much to lose if I can’t get on soon. Xbox game pass is absolute garbage. This sort of thing happens all the time for many different games. They need to be doing better. How can they offer a free play weekend if they’re not going to release the update…

1 Like

yeah it ruined my weekend too. And they won’t give us a time on the fix or anything just saying they are aware of the problem.

Just trying to play with my friends for the weekend, not going to bother downloading it on a different launcher just to have to uninstall and reinstall for PC Game Pass. Sucks that this probably won’t get fixed till Tuesday.

Glad I’m paying for a server I can’t even connect too! lol Is the xbox app the only platform that isn’t working??

Got the same issue. How is this not fixed? Having to Wait over a week and its still not working. Tried to reinstall but Nope didnt work.

Well they just did a patch and still can not play the game. I play on gamepass through xbox 1 console loads until I get your attributes have changed press A then it boots me out. I can play on the Siptah map though the lower half of the map has trouble rendering in.

Reinstall fix problem with update?

Yeah, still not fixed. On PC official server 1518 for PVE-C and it says invalid.

if we can’t give in, is our shit going to decay?

Reinstall fixed for me. Logged in and my base was not looted

Well i did find a loop whole to this and was kinda annoyin so when steam just had it as a free trial i installed the game through steam first then installed the PC game pass version this allowed me to play fine with other friends etc. So i would assume if someone you know who also has the game shared there steam library to allow your gamepass version to update and then just play through your game pass after the update has finished