Pets not leveling

Game mode: Online private
Type of issue: Misc
Server type: PvE
Region: America

  1. Capture baby animal
  2. Tame baby animal
  3. Provide food to tamed animal
  4. Place tamed animal on follow.
  5. Fight several creatures.
  6. Tamed animal does NOT level.

This ONLY seems to be happening with my character. My husband and another person on the server placed the very same animal on follow with them and were able to level the animal without an issue. I just finished leveling a greater black panther more than a week ago to level 20. I, also, leveled a second greater black panther to 20 less than a week ago. Now, I cannot get any other animal to level at all. I have noticed this issue within the last 5 days. I can level humanoid thralls with no issue. We are on a private server with mods and everything is up to date. No one else seems to be having this issue.

I do not want to have to recreate my character considering this will be the third time due to technical issues with the game in less than two months. l was very high level the previous two times as well as now. That would be disappointing and I would simply cease playing. No one wants to redo their character multiple times for issues caused by the game. Especially with no guarantee recreating the character will correct the issue.

Thank you for your assistance.

Are you using Better Thralls and multiple followers?

We have the mod Better Thralls, but I did not have additional followers at the time. I had one pet. Nothing happened no matter how many things I killed or how carefully I did it to assure the pet got a hit in.

And I had the pet as a normal follower not a better thrall follower. As I am sure that will be the next question.

You should check the settings in better thralls to see if there is one to set so all thralls receive xp while following or I am pretty sure there are different setting for thralls and xp.

I checked the Better Thralls settings. They were fine as they were. However, I did attempt to adjust them just to see. No change to leveling. Next, I adjusted the base server settings available to me and that did not affect it either. Also, I made the adjustments and picked up the pet, and put it back down. I made sure it had the right food. Still no change.

Little more than a week ago, I leveled a greater black panther to 20. Less than five days ago, I leveled a second greater black panther to 20 while the first one ran as a Better Thrall. No problems were noted. In the last several days, I cannot get animal thralls to level. Yet, I was able to get a humanoid thrall to level today without an issue.

The problem you might be facing is the following ( when you use the follow me on the wheel of choice , which follow me you chose , the original one , or the one added by better thralls ? ) I suggest you to use the original one ( cause followers , following with the better thralls folow me wont take xp )

I use the original one everytime.

I understand how the mods works. I do not believe the issue is with the mod. I tested both the settings of the base game and Better Thralls with the animal thrall on the base follow command from the game including picking up and putting down the animal after each change. Then I would go hit something and let the animal hit the same something until it was dead. No change in the animal thrall’s xp. Humanoid thralls are working just fine.

This is probably silly, but I have to ask, even though you seem to be an experienced player.

Have you validated your local files through Steam?

Can you level pets in a single player game without any mods? When I say no mods, that means moving the contents of your mod folder somewhere else, then validating again.



I am trying that right now. I thought about validating the files just as I laid down last night. I could not be bothered to get back up and do it last night.

So… Solved my own issue. Validating the files turned up nothing. Unsubscribed from mods, moved mod folder, loaded to main menu, resubscribed, checked mod folder, loaded to game, no change. In the end, the only thing I was left with was my character file had been corrupted in some manner. Much to my chagrin and dislike, I remade the character. Problem went away.

Thank you to those who tried to assist. I appreciate the consideration and suggestion. Happy gaming.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.