Progress not saving AGAIN!


I came back to this game after the age of sorcery update, I have bought several DLC’S and battle psss. This is probably my favourite game of all time. But it is sooo ridiculously broken.

For the third time now I have had my save file with probably 100’s of hours progress just break. Each time what typically happens is that I load my game and discover that my progress has not saved. This persists upon each attempt to continue. It just loads up at the same old save point I have wasted so much playtime its ridiculous/rant.

I have tried deleting/downloading game saves, reinstalling the game and starting over. But after so long… it just happens again. Now for the third time, the time and effort I’ve put kngo building my world/character is down the toilet. Why funcom…WHYYY! :upside_down_face:

Currently, my game is stuck ‘disconnecting from the game’ fir about 30 minutes. This also happened the first time and I know it won’t change.

I really so not want to lose this save as I have built so much. I only play pve on default private settings.

Does anyone know of a known fix?

Thankyou :slightly_smiling_face:

1 Like

Welcome to the Forum
Don’t know of a cure. When you logout do you check in with your bed and use quit? One player is building a wall or foundation then destroying it. Checking event log to see if it shows up giving a sense the game is tracking what is going on. :thinking: @lee1

Hi Sestus. Thanks, I did systematically check in with a bed before quitting the last time it happened but as the issue still occured I don’t bother now. This save has lasted the longest so far without doing that so I expect its not the problem.

I will ruminate on the rest of your reply and respond with any findings… thanks again :slightly_smiling_face:

Greetings lee1 and welcome to our forums!
Thank you for reaching out to us and reporting this issue.

May we ask if you’ve set your console to hibernation the day before noticing that your saved file was broken?

I would wait until Jun22 before throwing away that save. A lot of disconnection errors are claimed to be solved when the new update comes out. Maybe it gets fixed with the new update. Thats the only advise I can give you right now.

I feel your pain, I had similar problems in the past with my Singleplayer Games. I lost a 3 year old save with a good amount of unique buildings. I played SP inbetween mostly to blow of some steam from Pvp. To loose that save was very depressing for me.

I now play with my other half only pve and so we decided to rent our own server, which I personally find very pleasing. I do not have to be online for the ovens to burn through my stuff and the wheel of pain and animal pens etc. and we only had a couple of dc´s so far.

Please, don´t let yourself discourage from starting over again. See it as new chance to get creative again. We all improve over time and starting over sometimes allows us to create something completely new. Something we haven´t thought about before.


Thanks guys, and thanks for the encouragement Winthor.

HighSaint- I typically quit game and then leave the console in rest mode while on the main menu, do you think this could cause issues?

1 Like

My wife has been playing a offline solo game for a few weeks and shut down ps5 when done I don’t know if that forces a save or not but worth a try. @lee1

My advice to you is to:

  • make backups of your map on daily basis [you can do it using PlayStation+ cloud or using FAT32/exFAT formatted USB stick]
  • if you’re getting stuck on loading screen while exiting your solo map - before logging off wait 12 minutes then try to log out this way when game will get stuck on infinite loading screen when exiting you won’t loose progress - sometimes period of waiting may go up from 24 minutes uup to 48 minutes [in the most extreme cases] - this is how I keep crawling though Single Player on Exiled Lands making slowly progress - note if you got stuff crafting in benches getting stuck on loading screen propablity rises - when you obtained valubale item in the game - try to go somewhere safe and leave game for 12 minutes so you won’t loose it if game freezes and you’ll be forced to close it
1 Like

I did speak to a player who used the sleep emote, thinking that ended his game. Wasn’t working very well for him. He kept dying and losing his stuff.

Going to the menu and quitting is really the best way to make sure the save registers.

1 Like

That is what we do after sleep emote. @speedice

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.