Public Test Server US PvE - Serious Lag Issues

@Funcom-Dana - There are four of us on the Public Test Server US PvE. It has been suffering from lag since yesterday, but today it seems much worse. We have all tried restarting the game without any improvement.

Is there any chance this server can be restarted to see if that clears up the issue?

1 Like

Still trying to exit my hovel.

1 Like

Yes please! We’re all in here like… frustrated, just trying to play and have fun. Lost a thrall to a boss because I couldn’t have them refollow soon enough to move them.

I tried to play 2 Isle of Siptah test servers last night, both US, I think. Unplayable. I couldn’t even move.

1 Like

Hello everyone,

Poked the team for a server restart.

EDIT: Server has been restarted so it should be working again as intended. Feel free to let us know if you are still having issues.

Thank you for your patience!


Still the same issues. Yesterday several of us had Lost Connection to Host repeatedly. I reconnected 4 times in about a 5 minute span, while fighting a Mini-Boss Rocknose.

I was fighting 3 rocknose this morning and Lost Connection once. The rubberbanding has not improved after the restart.

I just lost connection a second time at the location where the red diamond marker is where there are three rocknose that respawned.

EDIT: Lost Connection a third time fighting at Sinner’s Refuge. The Lost Connections always seem to happen when going into combat.

Back on the server and it is once again time for THE SPINNERS to break out their hit! :grin:

1 Like

I ran across a couple of immense bases that seriously causes lag as all of the building pieces, benches, thralls and etc. render on the screen.

I think that is part of the issue with the server performance. The size of these bases are insane.

Yes, the Korea clan has multiple enormous bases with dozens of standing thralls, and I’ve never seen one of them online… They could be deleted, but keep the base in the volcano; I use their open map room all the time. :slight_smile:


PS, there has been no improvement in performance since before this topic was originally posted… I don’t think the fabled reboot ever happened.