Purge Doesn't Trigger At All

Game mode: Online private
Type of issue: Bug
Server type: PvP (technically)
Region: North America
Mods?: No
Edition: Steam

Bug Description:

My dedicated server is a fresh install as of 2021-12-08. I don’t have any mods installed. I’m using the dedicated server launcher v1.51 and I’ve modified the purge values in the server settings .ini away from the defaults as follows:

; Purge
EnablePurge=true
PurgeLevel=6
PurgePeriodicity=23
RestrictPurgeTime=false
PurgeRestrictionWeekdayStart=1900
PurgeRestrictionWeekdayEnd=2200
PurgeRestrictionWeekendStart=1800
PurgeRestrictionWeekendEnd=2300
MinPurgeOnlinePlayers=1
ClanPurgeTrigger=10500
ClanScoreUpateFrequency=15
PurgeDuration=60
PurgePreparationTime=15
AllowBuilding=false
PurgeNPCBuildingDamageMultiplier=(5.000000,5.000000,10.000000,15.000000,20.000000,25.000000)

I used these same defaults earlier in the year (Jan-Mar 2021) and the purge triggered exactly as expected.

I have yet to get a single purge to occur on my fresh server install. I am the only clan and the only player on my server and my purge bar is almost completely full.

I’ve tried a couple of different tweaks in an effort to troubleshoot and I can confirm that modifying PurgePeriodicity to a higher value, reducing MinPurgeOnlinePlayers to zero, quitting and restarting the game and restarting the server doesn’t help.

Steps to Reproduce:

  1. Install a dedicated server
  2. Connect to the server and create a character
  3. Create a clan
  4. Build a base and fill up your purge bar to the point where a purge should trigger
  5. Watch as no purge triggers.

Wak4863 did a stream on this:

No Purge Bases | Conan Exiles 2020 - YouTube

1 Like

Do you happen to have a time stamp where he addresses this? It’s a three and a half hour steam.

The matter comes down to the Purge being triggered once a base is at least a certain number of foundations – I think he said 92. The Purge will always look for a foundation and a wall to target. If that target can’t be reached, Purge will spawn inside the base.
I you use pillars instead of foundations the Purge won’t trigger for that base.

Hmmmm. Sounds easy enough to test. 92 foundations and a wall. I’ll try it out tomorrow.

I put down a little over a hundred foundations and 30’ ish wall segments in the flat space along noob river near Gallamans Tomb and still no purge. So, that’s not the problem.

Ah - that may be a factor (I’m not sure). There was a change made to purges an update or two back that means there is now a ‘no-purge’ zone. It’s supposed to only be on the south side of the river, but I seem to recall some suggestions from players that maybe it covered parts of the north bank as well. It might be worth trying a location further north, just to eliminate that possibility?

1 Like

That’s a good test as well. I had no idea that a ‘no-purge’ zone had been added.

1 Like

I managed to find @Wak4863’s video showing where the no purge zone is - looks like you might have been just inside it for your initial test -

2 Likes

Super helpful and likely the cause of my problems. I’ll test it shortly to be sure.

1 Like

Yep. That was it. Thanks for the help. This ticket can be closed as there’s no bug after all.

2 Likes

We’re glad the issue is now solved. Don’t hesitate to reach out if you encounter any other issues :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.