Red Mother after the 2.4 Patch

Just wanted to report that the fixes for fighting the Red Mother seem to have worked. I finally had a thrall fight her and my thrall did not sink into the mesh at all. The fight was right in the corrupted area that the Red Mother spawns at. I cannot say if results will be the same in other areas, outside of the corruption.

The one little glitch I ran into was that I could not use “E” to open her inventory after she died. I had to use “F” to pick up all to get what loot she dropped.

I play SP, Exiled Lands, with no mods.


That’s great news! As for the inventory glitch, does that happen every time? I’ve had that happen to me occasionally on the server where I used to play, but it was only from time to time.

1 Like

Any chance you can kite her to the staircase to fight? Curious to see if she still likes sinking through the map and squatting there till server restart.


Sorry it took this long to post a reply. After having a windows update and a Steam client update I was having major issues with Conan Exiles. The game was being difficult to load. So I verified the Conan Exiles files and reacquired 1 file. That took almost an hour of time.

Then after the reacquisition of the 1 file the game was pausing/freezing every couple of seconds, sounds were not playing and dead enemy “title” boxes were not even showing up. After about 5 minutes all these issues cleared up and I decided I should have Dalinsia test the Red Mother for a second time. The 1st time was with Beast Tamer Frida.

I did as requested and kited her to the stairs area but was met with somewhat glitchy results. When Dalinsia would sink half way into the ground she would attack and do damage to Mother. When she didn’t it seemed that she would only run/walk in place up against Mother. Also in the flat area between the stairs it seemed hard for Dalinsia to actually attack due to all her running/walking in place. So most of the battle actually took place on the sand next to the flat area. On the plus side is that the Red Mother never sank into the mesh.

I did encounter one other glitch. I was using @KiahonfireOfficial 's safe spot for fighting the Red Mother as a kind of safe “base.” Near the end of the fight Mother hit me with her fire breath attack 2x’s while I was there. I had trouble moving once her attack animation started.

As for the inventory glitch. It did not happen this time.

Anyways here’s a video of the 2nd fight with Red Mother. Sorry I didn’t do more between the stairs on the flat area. Also sorry the video is so long. That’s due to Dalinsia running/walking in place so much.


@Technicolorfool you definitely do not need to apologise for anything! You took the time to do something for someone you’ve never met before! I thank you :pray:. I can see from the video that it’s still very buggy on the stairs so I’ll just be fighting her on the flat ground to be safe. Thank you very much for testing this for me :+1: good luck in future bro, hopefully you don’t have these issues again.

1 Like

It mostly happens if the dragon shoots herself when she dies or falls from the stairs (a little bit under the terrain sometimes).
I would say every time when she does not die and collapse properly.
Those are just my experiences, maybe @Technicolorfool has different results.


Also cheers for the Lianelee video on your YouTube, I had no idea there was a chance for her to spawn there and I’ve been struggling to get a T4 dancer for my cimmerian base :+1::+1: I chucked a sub your way, keep up the good content.


I had never had this issue before mentioning it here. However, I think that you are probably right. After the 1st Red Mother fight I climbed up to the Watcher. When the Watcher died he fell off the the bridge or whatever it is he spawns on and his inventory also could not be accessed. :+1:

Thanks @Darkzombie. I’m not much of a YouTuber though. I really have no video editing skills. :rofl:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.