Says you do not have required dlc

Can somebody help me please? I definitly 100% own and bought and played isle of siptah dlc and now joining my private G Portal server this morning is telling me: You do not have the required dlc to play this server… And launches the isle of siptah page on steam which says in library and owned… If i right click conan exiles - properties - DLC isle of siptah is checked and installed aswell, I played yesterday and other days before… I need help please

Can you play the map in single-player, can you join an official server? Have you checked whether the DLC is activated on the steam page. (right click on the game in the library, properties and check the DLC tab).

Yes i mentioned above i checked the dlc in properties and I played just yesterday and this issue randomly came up today… I can’t join any server with siptah apparently the game doesn’t realise I own siptah anymore

It works single player, does this mean my g portal server got corrupted or something?

If you can play single-player, the game recognizes your DLC. It might a problem with the g-portal server somehow or your athentification when connecting to it.

Have you changed your steam name lately, does your steam name contain any special characters?

It works now my friend i restarted my G portal server properly :slight_smile: thank you so much and sorry for the trouble

1 Like

Glad it worked.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.