Server disconnects during a Purge

Hi,

We have had a problem for more than a week now that once a Purge is triggered, some 10-20 seconds into it, the server desyncs and drops the connection. This happens constantly, both during low- and high-level Purges. Reconnecting goes fast; however, once we reconnect, all the placeable wealth items outside of the coffer have to be repositioned to again count towards the total wealth, all ammo loaded into the ballistae is gone, and sometimes even a thrall or two turn up dead.

We run a dedicated server through G-portal and they have attempted several fixes, including moving the server and upping the hardware, to no avail, unfortunately. There is nought they can do since the problem seems to be a failed network code or some other connectivity bug.

We do also run mods on the server, and YES! - we have tested BOTH WITH and WITHOUT any mods, and the problem is still the same.

This is very frustrating since we cannot use one of the game’s intended prime mechanics. And the recent update did nothing to improve the situation either.
The Steam fora are dead for the answer, and the devs don’t seem to be aware of the problem.
Meanwhile, there are scores of players, both MP and SP, who report the same error. I also found records of the same error being present as far back as March 2023!

What do we do now, and - most importantly - what are the devs doing to address the issue?

Greetings @sanderbrown83 !

Thank you for reaching out to us.

Due to the fact that your issue is related to a private server, we would advise you to join the Admins United Discord (also referred on: Admins United: Conan - Discord for Server Admins! ) as this discord includes other admins with the experience to better assist you.

Continue conquering the lands!

Platform: Steam
Issue Type: Gameplay
Game Mode: Online Private
Server Type: PvE
Map: Exiled Lands
Server Name: 176.57.181.222, G-portal
Mods: Improved QoL; Emberlight; Glass Construction; Ancient Civilization; Thrall Wars Decoration; Better Thralls; Thrall War Dungeon Mod; EEWA; Valkyrian Arsenal & More (VAM); VAM Addon; Unlock Plus; LBPR - Additional Features

Bug Description:

The server desyncs and disconnects 10-20 seconds into a Purge. Happens every time, regardless of the Purge level and location on the map. After the dc, any treasure outside the coffer has to be re-positioned to count towards total wealth, and all siege weapons lose their ammo. Sometimes thralls turn up dead too. Has been happening to our server for 2,5 weeks now.
I have checked all the mods, they are validated and in the correct loading order.

Bug Reproduction:

Easily reproducible, you only need to trigger a Purge and start firing Noxious Gas arrows or just wait till a wave has spawned fully. Has been tested both with and without mods. Has been tested after “Repair server”, “Load backup” and after validating game files through the client. Appears to be the same kind of error many players had reported as far back as 2023, also with regards to being dc’ed during a Purge.

Sorry, but this is not a solution, you simply kick me over to a Discord channel for other admins. I can assure you, the fault does lie with the server, I have had G-portal devs look into it, it is the connectivity issue, most likely caused by the last two updates of the game.

It’s not a G-Portal issue that I can tell you.

I run a dedicated private server on a dedicated computer that only runs the server software with mods.

Tried 4 times now and every time I trigger a purge the entire server reboots.

removed some of the mods and tried again, and the chest is not in a heavy built area so that’s not the issue either.

It only happens when you trigger the purge, other then that the game works like a charm and I run 52 mods on it and the only time it crash is on a PURGE

So Funcom fix this crap please

[2024.06.29-11.23.33:263][ 50]LogWindows:Error: === Critical error: ===
[2024.06.29-11.23.33:263][ 50]LogWindows:Error:
[2024.06.29-11.23.33:264][ 50]LogWindows:Error: Fatal error: [File:C:\B\tech_exiles\code\Engine\Source\Runtime\CoreUObject\Private\UObject\ScriptCore.cpp] [Line: 1137]
[2024.06.29-11.23.33:264][ 50]LogWindows:Error: Failed to find function GetBuildingDamageMultiplier in BP_Purge_Engagement_DefenderFixating_C /Game/Maps/ConanSandbox/ConanSandbox.ConanSandbox:PersistentLevel.HumanoidNPCCharacter_C_766.Default__BP_Purge_Engagement_DefenderFixating_C_0
[2024.06.29-11.23.33:264][ 50]LogWindows:Error:
[2024.06.29-11.23.33:264][ 50]LogWindows:Error:
[2024.06.29-11.23.33:264][ 50]LogWindows:Error: !0x0000000000000000
[2024.06.29-11.23.33:264][ 50]LogWindows:Error:
[2024.06.29-11.23.33:270][ 50]LogExit: Executing StaticShutdownAfterError
[2024.06.29-11.23.33:896][ 50]LogWindows: FPlatformMisc::RequestExit(1)
[2024.06.29-11.23.33:897][ 50]Log file closed, 06/29/24 13:23:33