Siptah save corrupted on self-run dedicated server

I’m happy to link log files and the save DLC_Siptah.db itself.

I’ve been running an Exiles server for several years, and converted it to a Siptah world when it entered early access. My friends and I have put significant resources into it, but after the 2.4 update it will not run.

I run the game under Wine 6 on a Linux Mint 20 install.

While the game fails to load with database errors, if I remove the DLC_Siptah.db save and allow the game to start fresh and create a new world it’ll start and run just fine.

If I take the save file and transfer it to my gaming PC it’ll start the world as a Single Player game no problem.

I’ve removed and reinstalled the game several times from my server (managed through steamcmd). For the moment I’ve got a new world started successfully, but I’d love to get the old world and structures back for my players.

Any help would be appreciated, and I’ll update the post with the logs and db asap.

Do you use mods? You might have a better time troubleshooting this on the Admin discord:

If the main save is corrupted, have you tried a rollback using a backup?

Zero mods, because I didn’t want the hassle of maintaining them for every update.

I tried several backup DLC_Siptah.db files going back several weeks. I had the same problem going back at least a month which was my rolling backup length.