Steam Connect URL Not functioning

Game mode: [Online Official][Online Private]
Type of issue: [Misc]
Server type: [PvE]
Region: [USA]

[Describe the bug here]
When using a Steam Connect URL Steam will open a pop up box stating that Server not responding.
Steam URL example here would have logged you into official PVE server #1504

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Open up web browser and enter Steam URL example
  2. steam://connect/
  3. Steam pops up a box stating Server Not Responding.

This can be reproduced with private servers by logging into g-portal via your web browser.

  1. Open web browser and login to g-portal
  2. Navigate to Conan Private server
  3. Click on JOIN NOW button at top of the private hosted server.
  4. Steam pops up box stating server not responding.
1 Like

My server is having the same issue. Steam direct connect is not functioning properly. IP and steam query port are all correct and current.

1 Like

I have the same problem with my TRUGaming hosted server. I was told the hotfix did not address the problem with servers responding to queries from any source.
Clean server, fresh install, no mods
Start the server
The server will not respond in community list
The server will not respond to the hosts internal queries

Now the pop up from Steam is giving a:
“Unable to connect to server.
app id specified by server is invalid”

the same problem here :frowning:

“Unable to connect to server.
app id specified by server is invalid”

Ditto - been having this since the last update as well, meaning my friends and I haven’t been able to play the game since the update.

To those saying they can’t play: why don’t you guys connect by using the IP:Game Port instead of trying to connect with IP:Query Port?

Yes, steam direct connect doesn’t work anymore but the direct connect through the in-game server list does. Just make sure you are using the game port.


Ok so g-portal to launch your private server from their website uses Steam’s features.

Conan Exiles is a Steam game. For as long as I have been using Conan and been playing off of g-portal private servers this has worked fine.

Now it is broken and should be fixed. Period.

1 Like

Conan Exiles is a Funcom game, not a Steam game. For as long as you have been using Conan you have NEVER needed to connect via that method once.

Should it be fixed? Yes. But acting all pissy about it isn’t going to help your case.

One, I was not being pissy. If I was wanting to be pissy, trust me I can be pissy.

Two, I was stating this game is purchased on Steam and uses Steam features, not meaning it is produced or manufactured by Steam.

Three, I know several people who use this feature cause they are lazy and have their game server favorites in their browser and all they do is click their bookmark and then click join. Then Steam launches, then Steam starts Conan, and then Steam requests Conan connect to that server.

Also the fact that g-portal has this as part of their web UI and their name is also listed on the game intro videos. It would stand to reason that this is expected to work.


I am not sure how it works but will Epic Store players be able to use SteamAPI to direct connect to the servers from the rating sites without owning the game on Steam? If not, it is very unlikely that Funcom will go back to using it. They may come up with their own version of it though. Funcom need a solution that works for all not just the steam users because the epic players will be able to play on the same servers.

For me it worked if I use the local network IP for the server (my pc and the game server is on the same network (not the same pc)). Thanks for the suggestion.

I’d have to check with friends to find out if they can connect using the external IP and game client port.

Edit: The game took really log to get in, only to take me to the character creation screen :-(. Luckily have a server backup I can restore to (I hope that restores our game!)


So did the Steam Connect URL from the web browser work for you?

Or are you talking about some other bug in this thread? Cause this thread is discussing the Steam Connect URL stuff not working.

Ok, then I misinterpreted your text and I apologies for that.


Well there are so many unknowns on what is going on right now. Plus when you search there isn’t any usable information on what is going on.

It would be nice to have more clear information on what is going on what is changing and what is being removed or changed.

As far as Epic Games I am not sure on their end. All I can tell you in that g-portal assumes steam via their private hosting for the link at the top of your server.

So a lot of people and/or services are going to need to get up to speed.

As it stands I have 8 people now who have been calling me since I help them configure their servers through g-portal and I have no answers to give them on this issue or the new ones I have posted about that are also broken.

PS: Calls at 6AM when some someone can’t connect to their server is annoying lol


I was referring to Narelle’s suggestion of using the IP:Game Port via the Direct Connection option, rather than the IP: Query Port.

Hey there,

We’ll send this feedback to our team so they can look into it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.