Connection Failure - Could not connect to server. Your connection to the host has been lost

I have been trying ever since I was recommended by a friend to buy and play this game for a rented game server he has on Conan Exiles practically over a week ago to connect to his private server (which he plays on satelite internet keep in mind.) and along with any online server even the official servers for that matter, and I have tried everything… Always get “Connection Failure - Could not connect to server. Your connection to the host has been lost.” error every single time no matter what I try to do.

Searched forums, read blogs and tips/advice web-pages from other players who had similar issues and how to potentially fix and diagnose the issue. I have disabled firewall, norton antivirus, allowed a specific program “Conan Exiles” and “Steam” client to run through windows firewall as an “Allowed App To Communicate Through Windows Defender Firewall” I have a pretty fast, stable connection via ethernet straight into my computer running anywhere from 20-40mbps download / 3-10mbps upload consistently with ping under 100, latency under 50, 0% packet loss tested by “Ookla Speed Test” on various servers and ping host locations.

I have a expensive windows 10 HP All-In-One PC ($1200 PC) I bought in 2021 with a intel core i-3 quad core processor, 8GB ram, decent graphics card from Nvidia and nothing i’ve tried including search support forums for help on FunCom - Conan Exiles forums explains a reason or whim as to why I am unable to connect to any server private nor official after all this going at it diagnosis and fix this or tweak that after a full week…

When you have a new player who comes to play your game and MMORPG who was referred by word of mouth to come try and they spend money on a game they are unable to play right out the gate without going through 1000 unknown steps and processes and diagnosing and attempting to resolve the issue on their own with very little to go on and guidance just speculative ideas of what to try, it really is a bad look for a MMORPG of any sort.

I mean honestly… I should be able to buy this game, download its 8 long hour game files (which is incredibly long) 85 GB (Yikes) and be able to boot up the game and get into the game online immediately online without a hitch or hiccup leading to potentially weeks or longer (months?) at a time without being able to play the game ever except only in single player mode. I can play and login to any other MMORPG like Ultima Online, World Of Warcraft, League of Legends, Everquest 2 no problems. No diagnosis, no hard steps beyond simple installation… or if there is its clearly transparent, easy to understand and well laid out for any new potential player to join and get playing right away.

This game is riddled with bugs, obviously and apparently by all the thousands of bug reports, and its been around since January 31st 2017? Why is this an issue for any new coming player base at all in 2022 5-6 years later and why is this game not stable by now at this point its been 6 years since this game was initially developed FunCom what gives? Geez… Help or Refund!

I agree that there is something very wrong with the way the system works to try to connect to servers - I cannot join any server in the list by clicking on it and then clicking the “Join” button.That includes not being able to join a server I created which shows up on the list. From what I can tell by internet searches, it has been a problem for years and has not been fixed. I conclude, therefore, that Funcom is never going to fix it. In my opinion, it is also ridiculous that they require the IP address but no option for entering SomeHostname.AtMyDomain:PORT which they could resolve via hostname resolvers.They must deem not enough buyers of the game have the problem to make it worth their while.

IMO We have now both said enough about the BS of the connection operation. Here is how I got around the problem and a maybe for you depending on what your friend can do.

After neither my partner nor I could connect to the private server I built, I used the “Direct Connect” button connecting using the IP address assigned by my service provider, e.g. Both my partner and I successfully connected and are able to play. Note that I built the server on a different computer from the one on which I play the game so my game client has to go out on the network like my partner’s does.

I do not know what information/tools your friend has on a rented server. If he can get the IP address of his server and the port number used on that server, he can give you that to try to connect via “Direct Connect”. It is likely the default 7777 port is not used - there could be many servers on the machine and they need their different port numbers to separate them.

Greetings Exiles,

Thank you for your reports. Can you please share your log files with us?

You can find it by following:

Steam\steamapps\common\Conan Exiles\ConanSandbox\Saved\Logs

Feel free to reach out in private via direct message if you prefer.

Thank you in advance.


I am getting the same issue. Tried again today and no go. I have cancelled my dedicated server as everyone else could connect but I cannot. I can play in single player mode no problem but as soon as I try online it crashes with the same issues as above. I have tried dedicated servers, official servers and private.

I have a stable VERY fast connection that is wired. I have no issues playing any games online except Conan. Any help would be appreciated.