Still crashing . Losing faith

Has anyone (everyone, lol) with crashing issues checked their NAT type? Goto network settings and it should list it there. If it says anything but “open”, try forwarding (opening) these ports in your router (if possible).

Port 88 (UDP)
Port 3074 (UDP and TCP)
Port 53 (UDP and TCP)
Port 80 (TCP)
Port 500 (UDP)
Port 3544 (UDP)
Port 4500 (UDP)

Microsoft recommends this. I did it and it helped my crashing issues (not completely of course… come on funcom). And I have not had a chance to try the game since today’s update, so who knows what I’ll find today.

I would post the link but I’m new here and I’m not allowed to post links. Google search “Xbox live port forwarding” it should be one of the first in the list.


My Xbox is my DMZ…NAT is always open

1 Like

Get used to it, Gideon. Doesn’t seem like this crashing issue will ever be fixed for console players…

1 Like

I’m used to it now. I haven’t lost my corpse or my gear for about a week lol. What I do now is log off for 5 - 10 minutes after every major errand, (stealing thralls, collecting materials and fighting mobs) instead of having one huge session online and crashing 10 times. Have 10 play sessions and I disconnect when I want to, not when the game wants to :relieved: most of the time lol


I’ll have to give that a go and see if it works. I couldn’t even log in last night because the crashes were so bad.

Just seems like they went backwards instead of forwards with the latest patch.

Wow that sounds harsh. It’s never been quite that bad for me yet. Worse was crashing 3x in a row every hour or so but it hasn’t happened for around a week. Also plugged in my wired internet instead of using wi-if and NAT always been opened.
Crashing is though, without a doubt the most frustrating thing and just hope it can be fixed because it’s a really good game.


I was running along minding my own business when the game suddenly crashed, I waited in Solo player for a few mins and logged back on to find my self naked in the desert with none of my things. This has happened to me 4 times now and is really starting to grind my gears they need to fix this soon. It’s a shame really because other than the constant crashing it’s a really good game.

I feel your pain brothers and sisters. I to still have crashes on startup, personally i find loading single player for 30 seconds fixes the pvp server insta crashes.

But i still get crashes to dash after a period of time, no matter what im doing. Kindanused to it but annoyed because i dont want to use top equipment or travel around.

I play xbox 1, official pvp server.

I have a one x too and it’s happening too me as well.


Just started happening to me today after drinking a lotus potion to reset my attributes and feats after hitting 60.

Uh, don’t make statements like this unless you’re 100 percent sure of what you’re saying.

I upgraded my Xbox One S to an Xbox One X a few weeks ago.

I play single player, offline mode and I’ve had nothing but trouble.

My issues are for whatever reason I’ll exit the game normally and when I come back I’ll have NO items in my item wheel or on my person, all armor gone. This has happened 5 times since the last patch.

I’ve posted on here and have received NO responses from any mods or devs. I’ve also posted on Twitter and all they’ll say is “we’re striving to make the game the best it can be”. I’m calling bullshi*. Either this game is the worst port from a PC game ever, or they knew it was broke before they patched it and just don’t give a shi*.

1 Like

I’ve been watching a guy on Xbox x playing on mixer and he hasn’t crashed once while all his friends were constantly crashing again and again around him :rofl: was considering an upgrade myself but will probably wait for now

1 Like

It is weird. I was having the same issues on my Xbox One S and only decided to upgrade to the X because of my need/want for a 4K TV. I just wish they’d get it fix’d already or at least give us some clue that they acknowledge those of us that have it and what it could possibly be.


I have been able to play for varying amounts of time, but crashes and glitches have caused me to lose my gear 3 time in under a week. I just logged in and the world hadn’t rendered so I appeared in midair and fell until the world finally showed up and I died. I couldn’t recover my body because it was in a mountain that finally rendered over my corpse. Great job Funcom. Great job.

I have the X and I am currently experiencing this issue.

I’ve done this multiple times and it is not working. It used to work, before this latest ‘patch’, however. In fact, I was the one who shared this glitch with the community. Tried multiple other workarounds to no avail, this time, however… :confused:

It just amazes me that no matter how many people bring this issue up with Funcom, either the ability to not log on, the constant crashing, or, losing items we work hard to craft, Funcom NEVER, EVER responds.

I’ve gotten a few replies back from conanexiles on Twitter but its always “we’re working hard to make your experience the best it can be”. Instead of that how about acknowledging the issues we’re having?!?!

I just read shacknews review of Conan Exiles on Twitter, game it a 9/10 and was reviewed based on the PC version. Does anybody know for sure if the console versions were done as a port from the PC or were they stand-alone devs??? That would explain a lot of they were simply ports from the PC version.

I just wish they’d fix this sh*t already.

1 Like