Stuck in Activity Finder

Yesterday I attempted to use the Activity Finder to get into a Group to do E7-E9 dungeon runs. after waiting an hour i decided to Leave the Activity Finder to go do other things.
However now i can not Leave the Activity Finder.
I tried to click the LEAVE Button but nothing happens.
I tried to reboot the Game, However when i log back into the Game im still in Que in the Activity Finder.
I tried to reboot my computer and when i get back into game it still has me Qued.
I attempted to reload Game Data Base but still in Que.

this bug is stopping me from joining other groups to do dungeons .
neather can i do Scenerios or anything else that requires the Activity finder.
i will get the message that first i must Leave the present Que.

i would appreciate any help

Will uninstalling and then reinstalling the game be safe not to lose my character and his progress ?
And will it help me get rid of this Activity Finder bug ?

Characters are stored server side, so don’t worry about that.

That said, I don’t think reinstalling the game will help. At the very least try an repair first (done from the launcher).

I have attempted to repair once … will try again

did you open an in-game petition? if you’ve hit a bug on their side then that may be your only option.

Yes i have had an ingame petition now for over 24 hours and still waiting

Ok i have attempted a second Repair RDB , with same results.
I am still stuck in the Activity Finder and the LEAVE Button not doing anything

ok i uninstall and reinstalled game and that fixed the Activity Finder bug.
thank you everyone for your input


I’m sorry to hear you were stuck in the activity finder. This is rare, but we can easily fix it for you through a petition. Please submit one as quickly as possible letting us know that you are stuck in the activity finder. We’ll be happy to assist you with that and anything else that you might need help with.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.