Stuck on Loadingscreen after game crash

Hello, a friend of mine who plays on the same server as me (xbox isles of siptah EU 7002) has a problem. Today he was kicked out of the game and has not been able to join the server since then. Every time it gets stuck in the loading screen. Is there already a fix for it?

Restart the console and try again.
On series X, it works for me.
On the old big xbox one, the hdd is very slow, so it can time out the connection, if you are in a place, that has alot of buildings. That corrupted my solo save 4 times.

Thank you. But I have already restart the Console.
He has the Xbox one x.

He has already tried to connect to other servers, but he has the same problem there too.

He could try to move the game on an external SSD and start it from there.
Like i said, the internal hdd is slow.
I use an external SSD for X enhanced games and an external HDD for older games (regular xbox one and xbox 360 games).
Not 100% sure t will help, but it might be worth a try.

1 Like

We have reinstalled the game and now it works.

Oh dear… 100+ GB to download…
I had to do this a few days ago too, because of the X/S smart delivery update.
But good to hear, that it’s working again. Have fun playing

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.