The question of optimizing the game


#1

Good day! I have been playing the game Age of conan for a long time. I understand that the game is pretty old, but it does not make it bad. As far as I understand that from the beginning of the launch of the game the engine remained at the same level. The game loads only one processor core because of this the video card is not 100% loaded and there is no possibility to get a good FPS. And a reasonable question arises. Do you plan to somehow optimize the game for modern processors?


#2

I sincer hope they do. I got a gdeat laptop for this game but this issue drops my game to 20fps on ultra. I want to max the distance as well XD


#3

The game is in maintenance mode and has been so for some time. Funcom are most unlikely to do any major changes to the game engine at this point.


#4

There’s 0 chance of that happening. The amount of work that requires is not even close to feasible for the current state of the game.


#5

Great laptop and you have 20fps? Not that great as I see. I’ve got a RTX2060 geforce, i5 cpu along with 16gb RAM and SSD disc and my FPS never drops below 60 having graphic setting on ultra. The only exception is Pin Pin in Northern Grasslands where fps is kinda low. If you struggle with FPS however, keep graphic settings on ultra but turn off shadows, it may help.


#6

I have a 5yrs old alienware mx14 and I keep settings on high, particles on me only and 1000m distance and i have steady 60-80fps (except NG/zones with low fps). I don’t think it’s the game, maybe you have some bad settings video/windows. I’m not saying game it’s the best :slight_smile: but with a decent laptop you should get 50-60fps easy at high settings. Cheers


#7

I got ultra with everything except the pointless stuff. distance however, i have on specific settings since it is an issue i have.
Sadly, i got some problems with pc that requires me to hard reset it to get good fps but otherwise it works great. What is weird, is that in my case, 20fps seems to be locked in for some reason. i lower the settings to minimum, same fps. So i might just have some hard lock. but hell, game works well even on DX10…


#8

If you keep blinking your eyes real fast, fps seems to go up.


#9

That sounds sort of like what happens when the game is unfocused. I’ve heard it happens to people playing in Fullscreen mode at times. Sometimes alt-tab is enough to fix and get focus back. I play in windowed mode and never have that issue anymore.


#10

I seem to have 2 layers of this if i may call it that. First layer is the slight fps loss, alt tab gets rid of it.
Second layer is much riugher. Fps turns into weird choppy garbage fps. Requires hard reset (up to 3, usually 2 in my case) to fix. I kight check window mode tho and see if that fixes it.


#11

Hmmm, that’s strange. I had same issue but the other way around, windowed mode was giving me same fps when changing video settings. AOC it’s still AOC :slight_smile:


#12

the 2nd things looks like your gfx card and/or cpu goes into energy saving mode.


#13

How do i disable that on windows 10?


#14

Change to High Performance power plan in Energy settings. That will make sure your CPU doesn’t downclock while gaming. For the GPU, that only depends on whether it overheats or not, which is when it throttles down (you can also change to Maximum Performance in NVCP). You can set a custom fan curve with Afterburner to keep it more fresh.