The "Shadow Out of Time" achievement does not get triggered

Basic Info:

Platform: Steam
Issue Type: Other
Game Mode: Online Private

ver Type: PvE
Map: Exiled Lands
Server Name: =SERVER NAME=
Mods: =MODS=

Bug Description:

The “Shadow Out of Time” achievement does not trigger. Despite trying various weapon and armour recipes in countless numbers the game would not trigger this achievement.

Bug Reproduction:

Creating various Eldarium weapons, tools and armours on both an EL and on a Siptah private server with and without mods did not lead to the Steam achievement triggering.

Greetings Exile,

Thank you for your report. Can you share with us some examples of items you tried to craft with Eldarium on the server without mods?

We await your reply.


I tried a plethora of different weapons (about 20-30 different ones). Just to allow you to reproduce the bug, I just made the following three (again) to give you specific names:
Acidic Knives
Blasphemous Spears

This bug showed for me on my dedicated server with the Siptah map, the EL map and on single player.

Any update on this matter? The two weeks are almost over and I would not want this topic to ‘vanish’.

Still nothing? This is getting frustrating.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.