The story of my server and the Bugs I encountered

Game mode: [Online]
Problem: [Bugs]
Region: [Europe]
Mods: Several, listed below

Well I am a player of this game since the day it came out in EA, even though I took some longer breaks from time to time.

Some weeks ago I was starting it up again and got immediately hooked by it again so I decided to create a own private server together with my friend.

Since I encountered several issues along the way, also in single player, I thought I would create a different kind of bug-report outlining the evolution of the server and what issues we encountered along the way.

The Bugs I will stress in separate paragraphs and highlight them so it might be easier to skim through in case you do not want to read about the story itself, so here we go:

I rented the server with a German provider which means the server-language is German.

I tried to change that but it seems connected to the local language setting of the OS, if you know how to change that please let me know since I read some Bugs might come due to localisation.

When we started playing everything was Vanilla, after MOAP, since I could not access FTP to make changes, something I do not put on FUNCOM of course.

So we started south of the noob river, building our first and mediocre abode.


Since we both were eager to slay I wanted to trigger a purge, once I attained access to said FTP.

I filled our purge meter with the command "fillplayerclanpurgemeter" and "startnextpurgephase" (or whatever it is called, and yes I am aware there is one with a typo in it so I selected it from the suggestion in the admin-panel) but nothing happened.

No big deal we thought because I once read something purges do not work south of the noob-river.

So after some time we made our way up to the highlands where we wanted to build our main base.

We laid out our base in the bigger lake south-west of Asgard (North of Desertwatch, where the lorestone is located), and the grind became real, which I mitigated by adjusting the gathering rates a bit (3x).

We were kind of worried about getting hit by a strong Purge so I decided to change the settings to Purge Level 3 and "Number of online players" to 1, since I was quite worried about the Offline-Purges you read a lot in the forums.

As we built our base in Sandstone (Tier1), simply to lay it out and save resources, and progressed further in levels and building the Base with the final materials (we used pretty much every Tier because of style choices) we started wondering why no Purge is happening yet.


This was about the time we installed mods:

Pippi (Admin and Triggering of Meteor showers)

More female spawns (because we are men and women spawn quite rarely in our opinion)

No more Human Flesh (because it gets so annoying empty your inventory of human flesh which rots quite fast and does not provide much use)

Bigger stacks (because QOL)

Pickup+ (because building system is kind of wonky and why would I have to craft a workstation again just because I did not align it properly)

Fashionist (Because I want to have a specific skin of an Armor but the attribute points I like for my build [Encumbrance])

WYSIWYG Wheel of Pain (Because I can set the wheel to not be turning when empty, makes the base less noisy)

Bugfix mod to fix Wells/Hives/Fish-traps, which we replaced with the script in the link (Because we did not want to place all our Fish-traps after the daily server restart)



After our server was up for a week and our Purgemeter, yes we were in a Clan since we started playing, was filled this long as well there were still no purges.

I scoured these Forums as well as the internet and never found a solution helping my case in triggering a purge.

I set the "Online Players" to 0, changed to less than 24 Purges, enabled and disabled Purge times, allowed Building damage, switched Server to PVP, restarted the server many times, triggered all kind of console commands, enabled/disabled Purges entirely basically I fiddled around with every variable which was to be related, except the aforementioned Server language (German), with Purges but never even saw even the announcement.

Before you ask: Yes our base is located in the river but there is a clear path, about half a foundation height above the water surface, leading to our base (should be the choke point for the purge)

After that we became so unaware of the purge system we did not even bother to build defences for it.

For you to imagine the layout of our base, I can provide Pics should you be interested:

We have a big centre circle in the middle of the lake, where the foundation-path (mentioned above) leads to and represents our Palace.

The palace has, along its shape, a walkway.

Right behind the palace is another circle representing our Treasury and Quarters.

To either side of the Palace there are two other satellites adjacent to the walkway with 3 buildings and our Wheel of Pain.

[Wheel of Pain]

I figure the Greater Wheel of Pain requires a lot of space and it seems the collision-box is a circle and does not go along the shape of the wheel itself which is kind of counter intuitive, but this could be on my part.

As I bought the first DLC "The Imperial East Pack" I built our Palace and Treasury out of the new Khitan stuff, doing so I encountered many issues, most mentioned here already:

[The Imperial East Pack]

As I was replacing the Sandstone with the Khitan stuff I figured for the first time the building queue is cancelling the upcoming orders. Say you craft 10 Wedges followed by 10 Ceilings, you will just get 10 Wedges.

That was annoying for being charged 10 bucks but at least I get my Cold-Resistant Encumbrance Armor out of it, and the Art-style is truly great.

FUNCOM you have great artists in my opinion.

Another issue I encountered was, when removing the pillars, there is a sound but no breaking-animation and the pillar remains visible, but not interactable, after it vanishes after some time


By that time I found out that Wedges placed on top of Pillars are, per default, often facing the wrong direction clipping into ceilings and walls leaving a gap they were actually supposed to fill, so you need to turn the wedge first.

Furthermore it is not clearly visible in what directions the beams underneath the ceiling are placed when replacing an existing ceiling with a new one while looking top-down.

To overcome that you have to either destroy the existing ceiling or replace them from underneath. Why does the new ceiling not align according to the one you replace?

What also strikes me as odd is the fact you do not get refunded any material when upgrading building elements, often it is not possible do break the existing one because of structural integrity.

About the cost of materials, yes it is a not as clever choice to make insulated wood not viable up to when you unlock the fluid-press, I personally do not have a problem with using oil (even though I would have linked oil with black-ice instead of insulated wood to not run into this issue) since it is easy to come by with fish-traps, given they would not stop working until replaced after every restart.

Another thing I think it is curious is why do walls not, per default, align to the wall you want to place it above it? When do I need to have the outer face outside and on the wall one above inside?

Similar thing comes with pillars which, in some instances, are simply not able to be placed to have the face straight no matter how often you turn your mouse-wheel.

One of the greatest pains when building is certainly replacing existing Gates, the alignment and the amount of destruction and temporary construction are insane.


During our many runs to grind Thralls in New Asgard we figured, several times, that up to 5 NPC’s spawned on the same spot. This made it quite hard to clear the city with them also only being T1 and T2 and rarely T3, not to mention T4.

After we were grinding all the Thrall spots for over a week with only finding 1 (one) T4 Armorer, we decided to install another mod increasing the T4 Thrall spawns. Around then was the time the multiple spawns stopped, but could be a coincidence.

Many times when we kill an NPC and turn around to fight another one, the previously killed NPC is not rendered anymore until you go out of range and come back. I probably do not have to mention how irritating this might be especially when grinding for materials to please the gods.

Another issue is the fact that sometimes the NPC’s do teleport, more frequently seen with bosses, and, also reported several times, and thanks for taking a look into it, NPC’s and Thralls not being aggro.

[Gods and Temples]

Currently our base holds 4 T3 Temples and I figure the Derketo one does not have an Icon on the Map.

Further I personally think that the religious Armor of Mitra did not receive much love from you guys, the set is incomplete (just trousers and vest) and it is the same as the starter wraps but in blue, please let one of your art guys see to improve that to please Mitra:).


When having a Furnace which got oil (do not think that is relevant), glass-mould and glass inside of it add crystal and turn it on.

You will see the crystal will be queued to become glass, and there will be glass-flasks queued initially too but after the crystals are gone, the Furnace stops not producing glass-flasks.

[Jewel of the West DLC]

After buying the latest DLC, because I think it really looks amazing, I decided to upgrade our Temple from Khitan to Aquilonian, especially to highlight this regal atmosphere.

I was however astonished that it is not possible to upgrade from Khitan to Aquilonian but from Khitan to Black Ice for instance which lead to me tearing down the entire Palace first and then rebuild it.

Further the cancelling of the queue consists as with the Khitan DLC.

When crafting the Armor the queue work as long as you craft one piece, when attempting to craft more than one piece of the same Armor piece the following queue cancels again, same goes for the crafting of Weapons.

Why is the Aqilonian Spear requiring a Long-handle instead of a Spear-Handle as any Spear does, and why is the Spear-handle unlocked in Shaftmaker (you know for the short weapons like Daggers) in the first place?

What really bothers me is the missing attributes and temperature protection of the new Armor. From what I hear it is supposed to be Heat-protection and Vitality (might remember that one wrong) so not interesting for my build and I still can use the skins thanks to Fashionist mods because the artwork is again great.

I really do not understand one thing:

Why does the Khitan Armor lose its Attributes as well?

I crafted an Epic set to have my Encumbrance build in the North as well just to find out it no longer gives Attribute points, not even with a newly crafted Khitan Armor.

With all understanding this is not acceptable, I love that game, hence renting a Server, buying DLC and even gifting it to a friend so he can play with us.

I get that the art-team is doing most of those DLC’s but is it really necessary not only to bring a buggy DLC but also break a DLC which previously worked? Unfortunately I am not one of those getting the DLC for free since, by this hasty Test-event I already had RL-plans, but even if I would have gotten it for free, I would still be salty about it especially given that the Frost Temple is a really chore Temperature-.wise, even with epic Vanir.

[Misc stuff]

My colleague found a way to easily kill the boss in the Black keep, tried it myself and it is quite neat for SP.

I will not post how, because it might be a possible exploit, please advise if I shall report this.

The building restrictions around the Lorestone, you know at the Lake north of Desertwatch are funny to say the least.

I tried to expand our base to facilitate another Temple, which placement restriction is, in my personal PVE opinion, to great anyway, just to find out I cannot build too close to the Lorestone so I could not block it, which was not my intention at all.

I was able to overcome this restriction by placing the platform higher than I planned to leading to me being still able to block it of if I would like to do so.

Would it not be better to make the restricted area less high, so you could build a Platform above the Lorestone, but instead, in this case, restrict from building on the Path (about a foundation wide) leading to the Stone so all could always reach it?

The decorative warpaint vanishes at different times which I cannot find out when exatly but always when it happens it was after I died, but not every time I died it vanished.

I am talking about is named “Godslayer’s Tears” never tried another one.

When killing a Rhino it flies of like a little bird. Would it be possible for you to put some wings onto the Rhinos, you know the little ones like cupid has, this would look awesome :rofl:

Alright this text got longer than I anticipated so I will stop, for now.

Please let me know if I should register separate Bug-reports for all the mentioned issues I have.

I love that game and would like to see it thrive but I do not agree to some posts about Purge works, or as Jens-Erik pointed out in the Livestream (along the lines of) "You have to be more specific than Purge is not working". While I can understand that Jens-Erik said so I really do have a problem when it comes to encountering Purges.


Started to host a private server, needed to install Mods to mitigate some Bugs, never had a Purge in over two weeks but encountered several issues, especially with the last DLC breaking features of the first DLC.

Steps on how to reproduce issue:

  1. Rent server
  2. Play
  3. Install mods
  4. Buy DLC
1 Like

Here is the link of the server config I installed instead of the workshop mod, was not able to post links previously:

Serverside fix for fish-traps, bee-hives, wells and wheel of pain

i’m sorry man i stopped after the NPC part. i will maybe read the end an other time since it’s nicely written and pretty interesting. i agree with many things you explained, but i have right now one question for you:

Are you sure it was a T4 armorer and that you grabbed him in new asagarth? do you maybe remember his name? Was he Njoror battleborn? this guy has been recently highly looked for by the community, you know?

No worries, I know it is a word wall of text, I was just in the flow I guess.

Sorry for the confusion, no it was not in new Asagarth and therefore not Njoror Battleborn.
If I recall correctly the first one I found in the Den after several runs.

I got Njoror Battleborn after installing the mentioned mod, will include the link below, but the spawn rates are a bit too high I would say, but we are a small server and I made the members aware to intervene if it is too much for their taste.

Funny was we had an even harder time to get our hands to T3 or even T4 smelters, prior the mod of course.

More T4 spawns

Thanks for the reply mate.
yeah, too high rates can indeed kill the rare spawn hunt.
But i can also understand the frustration when someone is looking for a special thrall for hours / days in vain.

Will try to reach the top of your wall now :wink:

have you tried to put 2 molds in the furnace?

i felt the same way eventhough i took part of this “weird event”.

Have a quick look at that thread, tascha gave the appropriate link for such things

1 Like

No I did not, does not make a difference logical wise, but I will give it a try, thanks for the tip.
Still think there is something wrong here :slight_smile:

I think it was a cool idea to let the community test and reward them for it but the way it was executed was not optimal in my opinion.

They could have announced it more in advance and let the test run longer.
I was interested in testing, not only for the reward but weekdays I simply cannot play till 2 or 3 in the morning since I got a job, sucks to be me I guess :smiley:

There is no t4 armorer in asgarth

Spent 32 hours straight there and 1-3 tier popped that is it.

As I mentioned, he appeared after I installed the mod which, in its description, mentiones they had to activate several T4 to spawn in the Highlands

same for me, but it’s always worth to ask others…

hehe others said he did pop only reason why i stayed thank you so true.

This topic was automatically closed after 7 days. New replies are no longer allowed.