Thin armor plating not applying as desired

**Game mode:Online private
**Type of issue: Bug
Server type: PvE
**Region: EU

When I apply the “Thin armor plating” upgrade to a piece of armor, neitheir it’s durability, nor it’s armor value is improved. Worse, the durability of the piece of armor is reduced.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Create a piece of armor
  2. Create the “thin armor plating” upgrade
  3. Apply the “thin armor plating” to the newly created armor piece
  4. See that the armor piece has a durability decreased and no increase in “armor value”.

Just a heads up - when applying armor platings - or even flixibility kits - the durability is always reduced - this is also true for tools and weapons that have kits applied to them.

Not sure about the armor rating tho… Have you tried this with the normal or heavy plating? What armor are you attempting to apply the plating to?

1 Like

It could be that you have to make sure that you unclick (click on something else) on the piece of equipment you just modified and then re-click on it. The values don’t change until you come back to that piece and will show the old values until you do so.

1 Like

Also the armor platings are so weak they usually aren’t worth it. I think the strongest applies +3 armor? For -25% durability.


Agreed. I tried using the heavy plate once and was so disappointed that I’ve never considered using them again.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.