Things aren't spawning properly in single player

Game mode: [ Select one: (Single-player | Co-op)]
Type of issue: [ Select one: | Bug | ]
Server type: [ PvE ]
Region: [Vancouver, Canada
Hardware: [ X-box Series S ]

Bug Description:

*I first noticed the crocs weren’t spawning along one of the south east rivers and saw a temporary fix for that is to go into ghost mode, which seemed to help. But now the Riverwatch camp only has two enemies in it and I can’t save any thralls in the cages because the Jailor isn’t one of two spawns, and the ghost trick didn’t help here. I’m not sure how many other spawning issues there are, but it just seems generally quiet. I haven’t run into a hyena or the large elk that get aggressive, but I don’t know their spawning locations well so I’m not sure if that’s also an issue or if I haven’t come across their area. *

Expected Behavior:

I would love for everything to spawn in single player the same as it does for a server.

Steps to Reproduce:

  1. Go into a single player game.
  2. Go to Riverwatch camp and see if anything spawns other than an exile and a priest
  3. Go west along that river to the fork in the river and see if any of the 2 crocs that are supposed to be there have spawned.

It also seems to include scrolls - I’m at the spot to learn a dance near The Southwood and the ghosts appeared, but no scroll.

You would have got a pop up saying you learnt it. As for MIA mobs, admin, ghost mode then walk. You can also use admin for most patterns

The ghost mode worked for the crocodile spawns, but not for the Riverwatch camp unfortunately.

Try going to your base, enable admin cloak, then admin teleport to River watch and wait around for a few minutes without moving around too much

I’ve had a very similar issue on PS4.
The ghost and porting tricks do nothing for me on that platform for that specific area.
Good luck.

Hmm, nope that didn’t smarten it up at all (and I tried shutting off the game and doing it a couple of times to be sure). Thank you for trying to help though, I appreciate it

1 Like

Did anything work for youl? I’m debating uninstalling/reinstalling Siptah but I’m not sure if that would just be a waste of time

Riverwatch and westward is all abit buggy.

(ps4 anyway) only hyenas spawns, and Yog Pit is missing. No amount of waiting lets it load.

If you check under map from there to Ruins, abunch of stuff like branches, torches etc under map that aren’t on top.

Few Campfires are also missing. (one by mountainer has smoke, but no campfire)
One at Oasis is missing as well.

Havnt noticed any others off hand that were missing that badly.

1 Like

I’m not sure reinstalling is likely to make a lot of difference - missing enemies in singleplayer has been an issue for the past couple of patches (with one batch having disappeared with one patch, then most of them having come back and a different batch disappeared with the next patch).

The good news is, as far as I can tell so far, this seems to be fixed on testlive, suggesting it should be good once 2.6 goes live. Certainly all of the enemies I can think of that I knew were missing seem to be back (including some spawns I’d completely forgotten ever existing, lol) - I’ve checked the Exiled Lands more thoroughly than Siptah, but I did also find several ‘returners’ on Siptah that had previously been missing, so I’m hopeful this looks like it’s across the board. However, I haven’t remembered to check Riverwatch (which has been reported specifically by a few players) - I’ll make a note to check there just in case, but I’d say it’s looking pretty good so far.


Well this gives me hope, thank you so much!

1 Like

And more good news :slight_smile: I’ve just visited Riverwatch on live branch and on testlive (both singleplayer). Live there were only two npcs (neither of them the jailor), just as you mentioned, but on testlive the camp was as full as I would expect and the jailor was there. So it is looking very much as though these sapwn issues may be fixed :slight_smile:


Oh that’s exciting, thank you so much for checking that out! I was kind of ready to throw in the towel for a bit, but knowing that it’s being worked on gave me patience again, so thank you for that too haha


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.