Thrall won't come out of the water

In harbour of the twice drowned on siptah, where you have those three underwater sections that you need to swim through to get to the next part of the vault - went through the last one and my thrall stayed in the water - tried telling him to return, ordered to attack a nearby mob - even started combat and he stayed in the water - tried running back to the entrance - nothing. Could only get him back by exiting the vault - went back in and tried again, same thing

This happened to me but after a while he teleported back to my base.

Can happen now in any deep water, including noob river in the exiled lands. Never had a thrall get stuck in the water before 3.0. Now it’s too frequent. We don’t need more thrall bugs.

If I’m traveling or dungeon crawling with a thrall, I don’t need them to return home 30 minutes later. So I have to waste time by returning to where my thrall is located and move around on the nearest shore, hoping my thrall will respond.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.