Thralls and 1h-weapon issues

Game mode: Single player
Type of issue: Bug

I’ve noticed two issues regarding thralls and one handed weapons since patch 40

1- Thralls with 1h weapons and shields in inventory will only equip the shield when entering combat. They’ll run up to whatever they’re going to attack and follow it around, forgetting they have/need a weapon. Removing the shield from their inventory, even mid-attempted combat, will cause them to draw and attack as normal. This may be causing some ‘thralls not attacking’ reports.

2- The range at which Thralls will attack with 1h weapons is now extremely short. They’ll insist on getting right up in the face of whatever they’re attacking before trying to swing. This issue is also present with 2h weapons but is less pronounced as the AI seems to have a slightly farther range they’re allowed to start swinging from. This is making is harder for thralls to attack and making it appear the AI is sorta broke.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Go to Unnamed City with a fighter thrall with axe and shield.
  2. Order thrall to attack undead archer. Watch it run up shield out and stand there next to it.
  3. Remove shield from thrall and watch it draw axe and continue to run up to undead archer.
  4. Undead archer can’t switch to melee so it will back up. Thrall will chasing backing up archer till the heat death of the universe failing to attack even though it is really close.
  5. Give thrall a 2h weapon, once again mid combat., it will start swinging at the archer.

If anyone else can reproduce, chime in. This might clear up a chunk of AI problem reports.

I’ve noticed my thrall with a sword and board constantly equipping and storing the weapon, even when being actively attacked. Riocknose runs up. Thrall readies gear, then immediately puts it away. Rocknose attacks. Thrall readies gear, then puts away again. Rocknose continues to attack with impunity while the thrall stands there doing nothing.
Attack behavior: melee priority
Attack range: tested all (didn’t seem to matter)
Chase range: tested all (didn’t seem to matter)
Other: attack all enemies/defend me (didn’t seem to matter)

Something is broken. Badly. Only Pets seem to engage hostiles now.

1 Like

Try it with only the sword and no board? For science?

I was playing around today with a test server trying to crash it. There are some issues with the “offhand” because when you use 1h weapons you often get this warning entry in the server logs:

[2020.05.10-13.09.33:886][714]ItemInventory:Warning: Data: PersistentHumanoidNPC_C_4 tried to unequip left fist weapon to 0:3

I’ve noticed it with a torch and 1h weapon which used to work like a charm. Try forcing the weapon into the slot, this cleared the error for a while for me. If there is no off-hand to use, they seemed to attack normally for me, even though they re-equip the 1h weapon every time they finished off a mob or get cc-ed.

I should have included that in my report. I never had any luck force equipping the weapon. I tried, but only 3 or 4 times.

I’ve noticed the constant re-equipping as well, 1h and 2h, exactly like you describe. But I can’t remember if that’s how it was previous to the patch. Of course that’s because everything was working fine so I had no reason to scrutinize my thrall that closely. :laughing:

edit: I gave force equiping axe and shield one more go. It worked… for one mob, as soon as they finished the first and switched target, they did the re-equip dance and went back to shield with no weapon. :rofl:

Hey @FuzzySockSucker

Thanks for the heads-up, we’ve relayed this feedback to our team so they can look into it.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.