Thralls not regenerating health


#1

I have captured and knocked out multiple thralls, yesterday I had a level 2 fighter and after 24 hours there had been no regenerating of health, it has been stuck at 102. I am on PS4


Thralls are useless, because they dont heal. Official server. Needs attention ASAP
Thralls dont equip weapons
#2

Me and my friends have the same problem stuck on 102 health on every thrall and we have rank 3 thralls. I am pretty sure this is a glitch and I hope they see the complaints and fix it soon lol


#3

I’m having the same problem, I tried giving food to regenerate their health, but they don’t use it. Plus, I which there was a way to lock specific ones, to keep them from dying, similar to the system in MGS5 TPP where we could lock specific D-dog soldiers, so no matter what they wouldn’t get killed, I’ve got some pretty cool Thralls but some have already died, which kind of sucks


#4

I have same problem, they are easy to kill now and kinda useless.


#5

I also saw in other posts that you can’t equip bow or armor on them and that Thralls always stay in boxer stance. Sounds like a very annoying bug because I was realy looking foward to get some Thralls.


#6

Can also confirm thralls are not healing at all.
Even tried dancers / entertainers etc too heal, same problem.

They are just not working.


#7

As stated thralls dont heal up? All our thralls are one hit kills because they have max 100 hp - even our named thralls and tier3. Surely this has to be a bug? Needs fixed right now. Its a core feature, and the only way to defend a base in pvp.

This is on ps4 BTW. Is it the same for all or do they actually work for some People?


#8

nope deffo broke globally on ps4.


Thrall healing not working
#9

Hi all, this is a known issue on both Xbox and PS4. We’ll have it fixed next week.


Bugged Thralls - Any Patch Updates?
#10

It’s also impossible to equip thralls with weaponry on PS4 as of now. Hopefully this will get fixed as well.


#11

I have also that problem. Thralls dont regen health … Do u know where i can post.for some orhers bugs bcs i have equiped a piece of light armor but not working…


#12

Thralls not regenerating on consoles is a known issue and will be fixed in an upcoming patch. Equipping light armor and it not triggering the journey quest step is something we’re investigating. Thralls reportedly not being able to equip weapons will be looked at as well.

@GandalfTheSilver Sorry if this sounds like an elementary question, but are you able to open the thralls’ inventory at all?


#14

Aye, so I closed out the game and logged back in and I could equip armor on them again.
The boxer stance (ready combat stance - unarmed) happened when ever I tried to coerce my combat Thralls to equip their weapons (if I took a weapon from their … whopping 4 slot inventory they then “boxer stanced”) I noticed if I left them that way and went to do something else, by my return they stood as normal.


#15

Apologies for the late reply. Yes, the thralls’ inventories are accessible in every instance where I have tried accessing them. However, the main-hand and off-hand slots are unselectable with the cursor, even when a weapon/shield is selected. The only way thralls will equip weapons is when it is placed in their inventory and then during combat, the AI equips it to to their weapon slot. After combat, the AI seems to unequip the weapon and return it to one of their inventory slots.


#16

Others player can also kill my thralls on pve too is this known to u guys


#17

Hi. Is it next week yet? Purges are active. How do you defend??


#18

Other than a message a while ago saying it would be fixed this week have we had any word on this recently?


#20

still waiting on a fix since my purge meter is full and all the fighters/archers i turned into my thralls are placed and well they not recovering life. I don’t know if its just the PvE official servers are doing this or if its both PvE and PvP doing since i notice all the post don’t mention if its a PvE or PvP server they play on or even if its a rented server or single player. I’m on PvE.


#21

Still no word on this issue? It’s been over a week since the community manager said it would be fixed. Still an issue for me anyway.


#22

already “next week” … ends
Well … where?