Thralls/Pets not training

Online Private Solo
Bug
NA
USA
Yes
Steam

Bug Description:

Thralls and Pets not training. Will not show in the Queue. I am using correct foods/gruel. Have tried removing all mods, new Pens/Wheels. Different Placements, foundation or ground. Checked decay, there is none. Have read through all the other reports on here and tried all the responses. Still no help.

On the Wheel, the gruel disappears, but nothing in the queue. On the Pen, food doesn’t get used.


Expected Behavior:

Would expect the Thrall, or Pet to show in the crafting queue, but it does not.


Installed Mods:

N/A Tried with all mods removed and no difference in effect.


Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

Have you changed the crafting costs in the settings? This may affect the taming as well.

How about the thrall crafting multiplier?

… and don’t forget to press the play button.

2 Likes

It’s not the fact that the Thralls/Pets take too long, though I have tried adjusting them both up and down. They never show up in the crafting Queue.

And yes I did press the play button on the Wheel. There isn’t play button on the Animal Pens. They should take one food, and show in the Queue.

Plus, I can remove them with no warning message, which also shouldn’t happen.

If you can remove them, then their not started the taming process. Check you have the right pen, and the right food for them. It’s mostly that.

Try found out trough the wiki or other site what they need exactly, or make a test game, spawn one in admin mod, and look at their wished food when opening inventory. Test games are still fine to spot issue. A new DB and no mods at all, and you run some tests.

All my pets and thralls are training/taming fine, this on server, and SP as well.

1 Like

It’s not that I don’t appreciate the time you took to respond, but that’s why I said I have perused the forums on this topic. And tried everything that was advised.

I’m well aware of the food requirements. Tried both the high percentage food, and just the regular food. Yes, I am aware that pets go in pens, horses in stables, and thralls on the wheel.

I’m on a solo server right now, with admin. I’ve spawned pets, captured pets. Nothing.

Tried no mods, Mods. Adjusting settings, etc.

Here’s something interesting I found this morning.

On the thralls, If i adjusted the time slider all the way up. They showed in the queue. Then changed it back to lower than default, Destroyed the wheel, placed a new one and now it’s working.

On the stable, spawned a foal and it wouldn’t train. Spawned a horse and it doesn’t have a saddle box. But, it went in the stable and showed as it was training. LOL. So I guess you can teach an old horse new tricks.

The Pets? Still nothing works, but I’m gonna keep messing with it.

Thanks.

There must be something wrong on your side. I don’t see many complaints about pets not working in animal pens, or thralls not being trainable in the wheel.

I would check, or recheck the integrity of game-files, make sure the mod folder is clean (you can simply rename it in the meantime).
Of course resetting the sliders to default when you have some troubles is still a good thing to, especially if you fiddled lot around with them.

Like said, i have currently thralls turning in my wheels, and animals in my different pens. All doing fine.

2 Likes

I’m thinking it’s got to be something on my end too. Although, I did find a quite a few posts, here on the forum and on outside sites, that had the same problem with the pens.

I did check the integrity of game files, twice. All clear.

Deleted the server and started over, same problem.

About the only thing I haven’t tried yet, is to delete everything, Redownload the game and start over.

I still can’t figure out the horse thing. That should not work at all, but just logged in and yep, he’s training away, like he was just a brand new little pony. ha.

You mention private server, and from the context seem to mean on a local machine. Is this a dedicated server on a different machine from your game machine, a dedicated server instance running on the same machine, or are you playing single player not using a dedicated server instance?

If playing using a dedicated server, have you tested using single player mode to determine if it occurs there as well? Have you verified the installation of the server files in addition to the single player game files?

Have you tried installing the test-live build to see if it occurs there?

While I do recall seeing something like this several months ago, I’ve not encountered anything like this recently on my private server hosted online nor on my single player games.

1 Like

I’m running it as a dedicated server on the same machine.

I’ll try the test-live. I’ve got the thralls down, just the stable and animal pens still not putting the creature into the queue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.