Tinkerer journey broken

I cant complete the tinker journey step to make oil in a press it wont let me progress any ideas or is it glitched cause of a patch thing or something?

I will give it a try later today. @Chaos314699 . Not actually trying to do all of them.

1 Like

I am stuck at unlock armorsmith did it with a different character a few weeks back. Honestly prying kit kills durability.

1 Like

I did it on PC not on PS. The step validated after I put seeds AND fish in the press and I retrieved the oil made to put it in my inventory.


Yeah im just trying to do all journey steps this one just wont work tonight ill try putting just enough seeds an fish to make one oil each see if it works ive tried making it with just seeds an taking out the oil an seeds after same with fish doesnt wirk but havent tried them both at the same time ill try that thank u guys

Do u need help with armorsmith i did mine on ps4

1 Like

make sure you dont have oil in your inventory. That causes an issue on some journeys.


Thank u ill keep that in mind tonight when i try

1 Like

Have a level 60 character prybar is not helpful wish I could have helped earlier.

Yeah im 60 now on my new server still gonna have to try these fixs tonight i finished the tinker journey on offical servers but that was before last update afraid it had something to do with a glitch from most recent update

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.