Trying to recover my froobs

I click forgot password. OK.
Get e-mail with new password.
But is not working with that account.
I get it, you banned my paid because some wise guy thought to do nasty stuff, dunno what because you didn’t say.
But I cannot login to my froobs. I can login to that banned account …
I just want my 200 froobs, which I spent almost 15 years or more playing with them.
Help?

Try using this old login link: Funcom - Registration and Subscription (thesecretworld.com) When I need to reactivate my froobs, this is the link I use. G’luck!

Not working …

But when I try to login to game I get not paid. Because froob.
But on that link …

Log in failed

Are you sure you typed your password correctly?

Also, make sure your [CAPS LOCK]-key is not active.

Oh well. thanks anyway.

I had exact same issue on certain move:

I downloaded AO: New Client to my new PC and moved my prefs to new install. Then it gave me info that my frobs are NOT PAID.

So, I deledet AO, installed fresh client, and loged without problem.
Downside is, I had setup all stuff from start :confused:

it’s a fresh install

All the funcom account pages have a 24 hour lockout for your IP address if you log in or attempt to log in more than a handful of times. If you’re using a correct password and it’s not accepted, try waiting 24 hours, or use a VPN or e.g. the mobile internet on your phone. Once you’re in, Hunni’s link should let you reactivate your froob accounts, and then you should no longer get the error message in game.

Hope it helps!

tried those already. 6 months now already. of trying.

as you can see the account email database got faulty


I’m not sure what else could be wrong then I’m afraid. :pensive: Since you didn’t say it explicitly; I presume you’ve tried contacting Funcom support? Unfortunately I fully know they’re often unresponsive, but if you haven’t tried it yet, it’s probably a good idea to.

(Also for account security, I would recommend blurring out your user names from the screenshots.)

I logged in to AO’s webpage with my various accounts and passwords. They logged in fine, upgraded to new clients tried to log in to the game says incorrect logins, tried loggin back in to the webpage says
Authentication failed, please check your password and try again
Reset password still says
Authentication failed, please check your password and try again
Something is seriously messed up with funcom and their login system.
I started a new account, played an MP for an hour got kicked of, tried to log in to the website with the new account says
Authentication failed, please check your password and try again
reset password says
Authentication failed, please check your password and try again
tried to log back into the game says not paid!!!
WTF guys!

That invalid password message on the AO accounts website is from the IP Blocker. It happens after logging onto accounts several times in one day.

Once it’s blocked, it can take 24 hours or weeks before it clears up. Definitely wait at least 24 hours before trying to connect to any accounts. Otherwise, the 24 hour blocking timer starts over.

Block IP - Work Around

  • Wait a week or maybe a day for the hidden block to be lifted.
  • Connect computer to another internet access point. Try going to a coffee shop or library and use their internet connection. Maybe use a smartphone hotspot.
  • VPN can be used if you have access to one that allows connection to gaming sites.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.