Unable to craft DLC items

I was trying to craft the Turanian Caravan Rhino tonight and it wouldnt let me. I have the tamed rhino and the Turanian fodder in my inventory. The recipe shows that i have both and even has the craft button illuminated. But when i press X to craft it does nothing. I tried pressing triangle too, and nothing. I even tried spamming all combinations of the 2 buttons. Nothing. I also tried making the dlc bear with the same results. This is what made me think it was a dlc related bug. Went to my carpenters bench and sure enough, can’t craft a dlc bow. Is there a known bug with dlc right now?

Had this happen before log out an go in ps settings to ur account info an renew ur license at the bottom itll take a min then start conan everything is works right then keep having this problem since last update hope this helps


Good idea had to do that on ps4 regularly

Im on ps4 pro i have to do it twice a wk but my wifes ps pro never lol

1 Like

My wife and I play together in the same room gets funny when you can see each other and the difference between what is happening

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.